summaryrefslogtreecommitdiffstats
path: root/libcxx/CMakeLists.txt
diff options
context:
space:
mode:
authorEric Fiselier <eric@efcs.ca>2017-02-05 01:19:02 +0000
committerEric Fiselier <eric@efcs.ca>2017-02-05 01:19:02 +0000
commitf1fe87e60544dd9d8a350a97235419b904cd15c8 (patch)
treec4c7d46d751c2e32609948edb1849c0c4f26bddf /libcxx/CMakeLists.txt
parentcd1703b241509e3b4cf489a7456610fa3dcd9938 (diff)
downloadbcm5719-llvm-f1fe87e60544dd9d8a350a97235419b904cd15c8.tar.gz
bcm5719-llvm-f1fe87e60544dd9d8a350a97235419b904cd15c8.zip
Remove CMake hack
llvm-svn: 294116
Diffstat (limited to 'libcxx/CMakeLists.txt')
-rw-r--r--libcxx/CMakeLists.txt9
1 files changed, 0 insertions, 9 deletions
diff --git a/libcxx/CMakeLists.txt b/libcxx/CMakeLists.txt
index 4d65d2d22af..0b730529c5f 100644
--- a/libcxx/CMakeLists.txt
+++ b/libcxx/CMakeLists.txt
@@ -107,15 +107,6 @@ set(LIBCXX_CXX_ABI "default" CACHE STRING
set(CXXABIS none default libcxxabi libcxxrt libstdc++ libsupc++ vcruntime)
set_property(CACHE LIBCXX_CXX_ABI PROPERTY STRINGS ;${CXXABIS})
-# FIXME: This is a temporary hack to force LLVM buildbots to store
-# the fixed cache entry instead of the previous cache entry. This is needed
-# because some LLVM buildbots don't clear their cache. It will be removed
-# once all LLVM bots have been run.
-if (LIBCXX_CXX_ABI STREQUAL "")
- set(LIBCXX_CXX_ABI "default" CACHE STRING
- "Specify the C++ ABI library to use." FORCE)
-endif()
-
# Setup the default options if LIBCXX_CXX_ABI is not specified.
if (LIBCXX_CXX_ABI STREQUAL "default")
find_path(
OpenPOWER on IntegriCloud