summaryrefslogtreecommitdiffstats
path: root/libcxx/CMakeLists.txt
diff options
context:
space:
mode:
authorEric Fiselier <eric@efcs.ca>2015-06-13 07:31:55 +0000
committerEric Fiselier <eric@efcs.ca>2015-06-13 07:31:55 +0000
commited81d1c1f265be64053ff154e112b083bafe4b91 (patch)
tree3e408d3bbed608f0538110abe2f53573d43fcc91 /libcxx/CMakeLists.txt
parentde3f2b396c229399c00e3013aa060be3f0d336c1 (diff)
downloadbcm5719-llvm-ed81d1c1f265be64053ff154e112b083bafe4b91.tar.gz
bcm5719-llvm-ed81d1c1f265be64053ff154e112b083bafe4b91.zip
Remove warnings about old CMake options
llvm-svn: 239667
Diffstat (limited to 'libcxx/CMakeLists.txt')
-rw-r--r--libcxx/CMakeLists.txt21
1 files changed, 0 insertions, 21 deletions
diff --git a/libcxx/CMakeLists.txt b/libcxx/CMakeLists.txt
index 5c4c19fe111..4289c2a144f 100644
--- a/libcxx/CMakeLists.txt
+++ b/libcxx/CMakeLists.txt
@@ -104,27 +104,6 @@ set_property(CACHE LIBCXX_CXX_ABI PROPERTY STRINGS ;${CXXABIS})
# link with libunwind or libgcc_s while running the test cases.
option(LIBCXXABI_USE_LLVM_UNWINDER "Build and use the LLVM unwinder." OFF)
-# TODO(ericwf): Remove these options by March/25/2015.
-# These CMake options have been removed in favor of a generic option
-# "LIBCXX_CXX_ABI_INCLUDE_PATHS". Issue an explicit error message explaining
-# the change for anybody that still uses them.
-if (DEFINED LIBCXX_LIBCXXABI_INCLUDE_PATHS)
- message(FATAL_ERROR
- "The option \"LIBCXX_LIBCXXABI_INCLUDE_PATHS\" has been removed. "
- "Use \"LIBCXX_CXX_ABI_INCLUDE_PATHS\" instead "
- "and clean your build directory.")
-elseif(DEFINED LIBCXX_LIBSUPCXX_INCLUDE_PATHS)
- message(FATAL_ERROR
- "The option \"LIBCXX_LIBSUPCXX_INCLUDE_PATHS\" has been removed. "
- "Use \"LIBCXX_CXX_ABI_INCLUDE_PATHS\" instead "
- "and clean your build directory.")
-elseif(DEFINED LIBCXX_LIBCXXRT_INCLUDE_PATHS)
- message(FATAL_ERROR
- "The option \"LIBCXX_LIBCXXRT_INCLUDE_PATHS\" has been removed. "
- "Use \"LIBCXX_CXX_ABI_INCLUDE_PATHS\" instead "
- "and clean your build directory.")
-endif()
-
#===============================================================================
# Configure System
#===============================================================================
OpenPOWER on IntegriCloud