summaryrefslogtreecommitdiffstats
path: root/libcxx/CMakeLists.txt
diff options
context:
space:
mode:
authorEric Fiselier <eric@efcs.ca>2017-04-03 20:53:15 +0000
committerEric Fiselier <eric@efcs.ca>2017-04-03 20:53:15 +0000
commite4bda114530953554602e1e88db35f1ce65e3ed9 (patch)
tree58e4670477f083541ed08ecb2a55e8741491a905 /libcxx/CMakeLists.txt
parent1604f0773ba1d7e07083e8d31eec6ec88ccec2c8 (diff)
downloadbcm5719-llvm-e4bda114530953554602e1e88db35f1ce65e3ed9.tar.gz
bcm5719-llvm-e4bda114530953554602e1e88db35f1ce65e3ed9.zip
suppress GCC warning about noexcept functions changing mangling
llvm-svn: 299385
Diffstat (limited to 'libcxx/CMakeLists.txt')
-rw-r--r--libcxx/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/libcxx/CMakeLists.txt b/libcxx/CMakeLists.txt
index ffd8d532a72..53904a16aa6 100644
--- a/libcxx/CMakeLists.txt
+++ b/libcxx/CMakeLists.txt
@@ -466,7 +466,8 @@ if ("${CMAKE_CXX_COMPILER_ID}" MATCHES "Clang")
elseif("${CMAKE_CXX_COMPILER_ID}" MATCHES "GNU")
add_compile_flags_if_supported(
-Wno-literal-suffix
- -Wno-c++14-compat)
+ -Wno-c++14-compat
+ -Wno-noexcept-type)
endif()
if (LIBCXX_ENABLE_WERROR)
add_compile_flags_if_supported(-Werror)
OpenPOWER on IntegriCloud