summaryrefslogtreecommitdiffstats
path: root/libcxx/CMakeLists.txt
diff options
context:
space:
mode:
authorEric Fiselier <eric@efcs.ca>2014-11-18 21:26:45 +0000
committerEric Fiselier <eric@efcs.ca>2014-11-18 21:26:45 +0000
commit9b681f61b691050d4377646a7629694c5bcee8c1 (patch)
treee41317127dfab2980cb2658a5b3fb8ec3464ca96 /libcxx/CMakeLists.txt
parentbe6705d4a625105694c9a193239692ec21427e12 (diff)
downloadbcm5719-llvm-9b681f61b691050d4377646a7629694c5bcee8c1.tar.gz
bcm5719-llvm-9b681f61b691050d4377646a7629694c5bcee8c1.zip
Add support for LLVM_USE_SANITIZER=Thread
llvm-svn: 222259
Diffstat (limited to 'libcxx/CMakeLists.txt')
-rw-r--r--libcxx/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/libcxx/CMakeLists.txt b/libcxx/CMakeLists.txt
index 5fb0f60ad9d..f12c5257409 100644
--- a/libcxx/CMakeLists.txt
+++ b/libcxx/CMakeLists.txt
@@ -229,6 +229,8 @@ if (LIBCXX_BUILT_STANDALONE)
elseif (LLVM_USE_SANITIZER STREQUAL "Undefined")
list(APPEND LIBCXX_CXX_FLAGS
"-fsanitize=undefined -fno-sanitize=vptr,function -fno-sanitize-recover")
+ elseif (LLVM_USE_SANITIZER STREQUAL "Thread")
+ list(APPEND LIBCXX_CXX_FLAGS "-fsanitize=thread")
else()
message(WARNING "Unsupported value of LLVM_USE_SANITIZER: ${LLVM_USE_SANITIZER}")
endif()
OpenPOWER on IntegriCloud