summaryrefslogtreecommitdiffstats
path: root/libcxx/CMakeLists.txt
diff options
context:
space:
mode:
authorPetr Hosek <phosek@chromium.org>2017-12-01 03:16:50 +0000
committerPetr Hosek <phosek@chromium.org>2017-12-01 03:16:50 +0000
commit363c631edd68096939adf12ba33401d698c14ad8 (patch)
tree4b5478685c691144b7933e87f16dab93d92a767a /libcxx/CMakeLists.txt
parent11f733df9b60c8c518730dac17a5c16b6ce09022 (diff)
downloadbcm5719-llvm-363c631edd68096939adf12ba33401d698c14ad8.tar.gz
bcm5719-llvm-363c631edd68096939adf12ba33401d698c14ad8.zip
Include AddLLVM needed for tests in the right context
AddLLVM is needed for several functions that are used in tests and as such needs to be included from the right context which previously wasn't the case. Differential Revision: https://reviews.llvm.org/D40280 llvm-svn: 319515
Diffstat (limited to 'libcxx/CMakeLists.txt')
-rw-r--r--libcxx/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/libcxx/CMakeLists.txt b/libcxx/CMakeLists.txt
index f0c4d1efb07..29eef8f35db 100644
--- a/libcxx/CMakeLists.txt
+++ b/libcxx/CMakeLists.txt
@@ -684,6 +684,7 @@ if (LIBCXX_INCLUDE_TESTS)
endif()
if (LIBCXX_STANDALONE_BUILD AND EXISTS "${LLVM_MAIN_SRC_DIR}/utils/llvm-lit")
+ include(AddLLVM) # for get_llvm_lit_path
# Make sure the llvm-lit script is generated into the bin directory, and do
# it after adding all tests, since the generated script will only work
# correctly discovered tests against test locations from the source tree that
OpenPOWER on IntegriCloud