summaryrefslogtreecommitdiffstats
path: root/libcxx/CMakeLists.txt
diff options
context:
space:
mode:
authorZachary Turner <zturner@google.com>2017-09-19 03:11:35 +0000
committerZachary Turner <zturner@google.com>2017-09-19 03:11:35 +0000
commit0556b995e19b96c4f59ce2e3da01cabda87a36e2 (patch)
tree6a630da690f61f56d52287c94920b5b363f6e4d7 /libcxx/CMakeLists.txt
parentcbafb0f8e1d2919396b77d8b855944bc89f17c32 (diff)
downloadbcm5719-llvm-0556b995e19b96c4f59ce2e3da01cabda87a36e2.tar.gz
bcm5719-llvm-0556b995e19b96c4f59ce2e3da01cabda87a36e2.zip
Revert "Fix llvm-lit script generation in libcxx."
This reverts commit 4ad71811d45268d81b60f27e3b8b2bcbc23bd7b9. There is a bot that is checking out libcxx and lit with nothing else and then running lit.py against the test tree. Since there's no LLVM source tree, there's no LLVM CMake. CMake actually reports this as a warning saying unsupported libcxx configuration, but I guess someone is depending on it anyway. llvm-svn: 313607
Diffstat (limited to 'libcxx/CMakeLists.txt')
-rw-r--r--libcxx/CMakeLists.txt10
1 files changed, 0 insertions, 10 deletions
diff --git a/libcxx/CMakeLists.txt b/libcxx/CMakeLists.txt
index f2b7f83dd01..e402dae665a 100644
--- a/libcxx/CMakeLists.txt
+++ b/libcxx/CMakeLists.txt
@@ -653,7 +653,6 @@ endif()
#
# However, since some submission systems strip test/ subdirectories, check for
# it before adding it.
-
if(IS_DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}/test")
add_subdirectory(test)
endif()
@@ -661,15 +660,6 @@ if (LIBCXX_INCLUDE_TESTS)
add_subdirectory(lib/abi)
endif()
-if (LIBCXX_STANDALONE_BUILD AND EXISTS "${LLVM_MAIN_SRC_DIR}/utils/llvm-lit")
- # Make sure the llvm-lit script is generated into the bin directory, and do
- # it after adding all tests, since the generated script will only work
- # correctly discovered tests against test locations from the source tree that
- # have already been discovered.
- add_subdirectory(${LLVM_MAIN_SRC_DIR}/utils/llvm-lit
- ${CMAKE_CURRENT_BINARY_DIR}/llvm-lit)
-endif()
-
if (LIBCXX_INCLUDE_DOCS)
add_subdirectory(docs)
endif()
OpenPOWER on IntegriCloud