summaryrefslogtreecommitdiffstats
path: root/debuginfo-tests/CMakeLists.txt
diff options
context:
space:
mode:
authorZachary Turner <zturner@google.com>2017-11-16 18:26:20 +0000
committerZachary Turner <zturner@google.com>2017-11-16 18:26:20 +0000
commit5e420717a1c4d9b25c645362f92dc02ccf2c5977 (patch)
treee921704288f4fd9a5ce7904c3083bdd20fdce4c9 /debuginfo-tests/CMakeLists.txt
parent2139ed638b7c14eff603ba6b3a67753fe5020063 (diff)
downloadbcm5719-llvm-5e420717a1c4d9b25c645362f92dc02ccf2c5977.tar.gz
bcm5719-llvm-5e420717a1c4d9b25c645362f92dc02ccf2c5977.zip
Resubmit "Refactor debuginfo-tests"
This was reverted due to some failures on specific darwin buildbots, the issue being that the new lit configuration was not setting the SDKROOT environment variable. We've tested a fix locally and confirmed that it works, so this patch resubmits everything with the fix applied. llvm-svn: 318435
Diffstat (limited to 'debuginfo-tests/CMakeLists.txt')
-rw-r--r--debuginfo-tests/CMakeLists.txt36
1 files changed, 36 insertions, 0 deletions
diff --git a/debuginfo-tests/CMakeLists.txt b/debuginfo-tests/CMakeLists.txt
new file mode 100644
index 00000000000..60a467fec85
--- /dev/null
+++ b/debuginfo-tests/CMakeLists.txt
@@ -0,0 +1,36 @@
+# Debug Info tests. These tests invoke clang to generate programs with
+# various types of debug info, and then run those programs under a debugger
+# such as GDB or LLDB to verify the results.
+
+set(DEBUGINFO_TESTS_SOURCE_DIR ${CMAKE_CURRENT_SOURCE_DIR})
+set(DEBUGINFO_TESTS_BINARY_DIR ${CMAKE_CURRENT_BINARY_DIR})
+
+set(DEBUGINFO_TEST_DEPS
+ clang
+ llvm-config
+ FileCheck
+ count
+ not
+ )
+
+get_target_property(CLANG_SOURCE_DIR clang SOURCE_DIR)
+
+if (TARGET lld)
+ set(DEBUGINFO_TESTS_HAS_LLD 1)
+ list(APPEND DEBUGINFO_TEST_DEPS lld)
+ get_target_property(LLD_SOURCE_DIR lld SOURCE_DIR)
+endif()
+
+configure_lit_site_cfg(
+ ${CMAKE_CURRENT_SOURCE_DIR}/lit.site.cfg.py.in
+ ${CMAKE_CURRENT_BINARY_DIR}/lit.site.cfg.py
+ MAIN_CONFIG
+ ${CMAKE_CURRENT_SOURCE_DIR}/lit.cfg.py
+ )
+
+add_lit_testsuite(check-debuginfo "Running debug info integration tests"
+ ${CMAKE_CURRENT_BINARY_DIR}
+ DEPENDS ${DEBUGINFO_TEST_DEPS}
+ )
+
+set_target_properties(check-debuginfo PROPERTIES FOLDER "Debug info tests") \ No newline at end of file
OpenPOWER on IntegriCloud