summaryrefslogtreecommitdiffstats
path: root/compiler-rt/test/CMakeLists.txt
diff options
context:
space:
mode:
authorErik Pilkington <erik.pilkington@gmail.com>2017-03-09 14:17:36 +0000
committerErik Pilkington <erik.pilkington@gmail.com>2017-03-09 14:17:36 +0000
commit6fa97926e910b2ebaa3b8c2ce70f9a27320d0be0 (patch)
tree5fc6bb9cd3b7ec802e3221638f3bbf66025532cb /compiler-rt/test/CMakeLists.txt
parente86b7e2256dec3e7f385ebced827f91a60af2bb7 (diff)
downloadbcm5719-llvm-6fa97926e910b2ebaa3b8c2ce70f9a27320d0be0.tar.gz
bcm5719-llvm-6fa97926e910b2ebaa3b8c2ce70f9a27320d0be0.zip
[compiler-rt][builtins] Add __isOSVersionAtLeast()
This predicate compares the host's marketing OS version to one passed as argument. Currently, only darwin targets are supported. This is done by parsing the SystemVersion.plist file. Also added in this patch is some lit testing infrastructure for builtins, which previously had none. This part of the patch was written by Alex Lorenz (with some minor modifications). This patch is part of a feature I proposed here: http://lists.llvm.org/pipermail/cfe-dev/2016-July/049851.html Differential revision: https://reviews.llvm.org/D30136 llvm-svn: 297382
Diffstat (limited to 'compiler-rt/test/CMakeLists.txt')
-rw-r--r--compiler-rt/test/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/compiler-rt/test/CMakeLists.txt b/compiler-rt/test/CMakeLists.txt
index 9b9c515a304..addc579973b 100644
--- a/compiler-rt/test/CMakeLists.txt
+++ b/compiler-rt/test/CMakeLists.txt
@@ -5,9 +5,8 @@ configure_lit_site_cfg(
${CMAKE_CURRENT_SOURCE_DIR}/lit.common.configured.in
${CMAKE_CURRENT_BINARY_DIR}/lit.common.configured)
-# BlocksRuntime and builtins testsuites are not yet ported to lit.
+# BlocksRuntime (and most of builtins) testsuites are not yet ported to lit.
# add_subdirectory(BlocksRuntime)
-# add_subdirectory(builtins)
set(SANITIZER_COMMON_LIT_TEST_DEPS)
if(COMPILER_RT_STANDALONE_BUILD)
@@ -39,6 +38,9 @@ endif()
# Run sanitizer tests only if we're sure that clang would produce
# working binaries.
if(COMPILER_RT_CAN_EXECUTE_TESTS)
+ if(COMPILER_RT_BUILD_BUILTINS)
+ add_subdirectory(builtins)
+ endif()
if(COMPILER_RT_HAS_ASAN)
add_subdirectory(asan)
endif()
OpenPOWER on IntegriCloud