summaryrefslogtreecommitdiffstats
path: root/compiler-rt/lib/scudo/standalone/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorKostya Kortchinsky <kostyak@google.com>2019-06-17 15:23:11 +0000
committerKostya Kortchinsky <kostyak@google.com>2019-06-17 15:23:11 +0000
commite4eadf174cb1e8e5ea5bee6d4a99461d72205659 (patch)
tree808c7af82e794ea4e771ad8a284cdbf8f2a09c24 /compiler-rt/lib/scudo/standalone/tests/CMakeLists.txt
parentb5ce4e5ea3e101011d030f38e01df6c0b059820a (diff)
downloadbcm5719-llvm-e4eadf174cb1e8e5ea5bee6d4a99461d72205659.tar.gz
bcm5719-llvm-e4eadf174cb1e8e5ea5bee6d4a99461d72205659.zip
[scudo][standalone] Introduce the combined allocator
Summary: The Combined allocator hold together all the other components, and provides a memory allocator interface based on various template parameters. This will be in turn used by "wrappers" that will provide the standard C and C++ memory allocation functions, but can be used as is as well. This doesn't depart significantly from the current Scudo implementation except for a few details: - Quarantine batches are now protected by a header a well; - an Allocator instance has its own TSD registry, as opposed to a static one for everybody; - a function to iterate over busy chunks has been added, for Android purposes; This also adds the associated tests, and a few default configurations for several platforms, that will likely be further tuned later on. Reviewers: morehouse, hctim, eugenis, vitalybuka Reviewed By: morehouse Subscribers: srhines, mgorny, delcypher, jfb, #sanitizers, llvm-commits Tags: #llvm, #sanitizers Differential Revision: https://reviews.llvm.org/D63231 llvm-svn: 363569
Diffstat (limited to 'compiler-rt/lib/scudo/standalone/tests/CMakeLists.txt')
-rw-r--r--compiler-rt/lib/scudo/standalone/tests/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/compiler-rt/lib/scudo/standalone/tests/CMakeLists.txt b/compiler-rt/lib/scudo/standalone/tests/CMakeLists.txt
index 397092ce070..9167ba7c46a 100644
--- a/compiler-rt/lib/scudo/standalone/tests/CMakeLists.txt
+++ b/compiler-rt/lib/scudo/standalone/tests/CMakeLists.txt
@@ -53,6 +53,7 @@ set(SCUDO_UNIT_TEST_SOURCES
bytemap_test.cc
checksum_test.cc
chunk_test.cc
+ combined_test.cc
flags_test.cc
list_test.cc
map_test.cc
OpenPOWER on IntegriCloud