summaryrefslogtreecommitdiffstats
path: root/compiler-rt/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorMichal Gorny <mgorny@gentoo.org>2017-10-02 05:03:55 +0000
committerMichal Gorny <mgorny@gentoo.org>2017-10-02 05:03:55 +0000
commit806b8d56a2b28e7f16945cfa78affb9fdce16179 (patch)
treec5bb8a66668e0646f5e18bd873111bfdf2ca45e0 /compiler-rt/lib/CMakeLists.txt
parentdaf5adc6c1b689517f9b7f3f0ad18f1481034eba (diff)
downloadbcm5719-llvm-806b8d56a2b28e7f16945cfa78affb9fdce16179.tar.gz
bcm5719-llvm-806b8d56a2b28e7f16945cfa78affb9fdce16179.zip
[cmake] Add a separate CMake var to control profile runtime
Make it possible to control building profile runtime separately from other options. Before r313549, the profile runtime building was controlled along with sanitizers. However, since that commit it is built unconditionally which results in multiple builds for people building different runtimes separately. Differential Revision: https://reviews.llvm.org/D38441 llvm-svn: 314646
Diffstat (limited to 'compiler-rt/lib/CMakeLists.txt')
-rw-r--r--compiler-rt/lib/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/compiler-rt/lib/CMakeLists.txt b/compiler-rt/lib/CMakeLists.txt
index a92d0a3f082..b3731f653a0 100644
--- a/compiler-rt/lib/CMakeLists.txt
+++ b/compiler-rt/lib/CMakeLists.txt
@@ -41,7 +41,7 @@ if(COMPILER_RT_BUILD_SANITIZERS)
endforeach()
endif()
-if (COMPILER_RT_HAS_PROFILE)
+if(COMPILER_RT_BUILD_PROFILE AND COMPILER_RT_HAS_PROFILE)
compiler_rt_build_runtime(profile)
endif()
OpenPOWER on IntegriCloud