summaryrefslogtreecommitdiffstats
path: root/clang/test/CXX/temp/temp.fct.spec/temp.arg.explicit
diff options
context:
space:
mode:
authorDaniel Dunbar <daniel@zuster.org>2009-12-15 20:14:24 +0000
committerDaniel Dunbar <daniel@zuster.org>2009-12-15 20:14:24 +0000
commit8fbe78f6fc7b41d1a4228c126fcb522131150518 (patch)
tree979638dbf763f78210cb4784cda2f95084d3b72a /clang/test/CXX/temp/temp.fct.spec/temp.arg.explicit
parenta3aef788ec802875e26fc014a4040a024eb2b506 (diff)
downloadbcm5719-llvm-8fbe78f6fc7b41d1a4228c126fcb522131150518.tar.gz
bcm5719-llvm-8fbe78f6fc7b41d1a4228c126fcb522131150518.zip
Update tests to use %clang_cc1 instead of 'clang-cc' or 'clang -cc1'.
- This is designed to make it obvious that %clang_cc1 is a "test variable" which is substituted. It is '%clang_cc1' instead of '%clang -cc1' because it can be useful to redefine what gets run as 'clang -cc1' (for example, to set a default target). llvm-svn: 91446
Diffstat (limited to 'clang/test/CXX/temp/temp.fct.spec/temp.arg.explicit')
-rw-r--r--clang/test/CXX/temp/temp.fct.spec/temp.arg.explicit/p1.cpp2
-rw-r--r--clang/test/CXX/temp/temp.fct.spec/temp.arg.explicit/p3.cpp2
2 files changed, 2 insertions, 2 deletions
diff --git a/clang/test/CXX/temp/temp.fct.spec/temp.arg.explicit/p1.cpp b/clang/test/CXX/temp/temp.fct.spec/temp.arg.explicit/p1.cpp
index 088a9e55eb3..0aef6adad13 100644
--- a/clang/test/CXX/temp/temp.fct.spec/temp.arg.explicit/p1.cpp
+++ b/clang/test/CXX/temp/temp.fct.spec/temp.arg.explicit/p1.cpp
@@ -1,4 +1,4 @@
-// RUN: clang-cc -fsyntax-only %s
+// RUN: %clang_cc1 -fsyntax-only %s
template<typename T> struct A { };
diff --git a/clang/test/CXX/temp/temp.fct.spec/temp.arg.explicit/p3.cpp b/clang/test/CXX/temp/temp.fct.spec/temp.arg.explicit/p3.cpp
index 01030b2a8a2..d0cb42da6ed 100644
--- a/clang/test/CXX/temp/temp.fct.spec/temp.arg.explicit/p3.cpp
+++ b/clang/test/CXX/temp/temp.fct.spec/temp.arg.explicit/p3.cpp
@@ -1,4 +1,4 @@
-// RUN: clang-cc -fsyntax-only -verify %s
+// RUN: %clang_cc1 -fsyntax-only -verify %s
template<class X, class Y, class Z> X f(Y,Z);
OpenPOWER on IntegriCloud