summaryrefslogtreecommitdiffstats
path: root/clang/runtime/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Bieneman <beanz@apple.com>2016-06-28 18:32:22 +0000
committerChris Bieneman <beanz@apple.com>2016-06-28 18:32:22 +0000
commitce45e39c24faddce0afa7024934ede455dc5206b (patch)
tree816ee9b41b4394992226f122d8b356cedcaa9739 /clang/runtime/CMakeLists.txt
parent70d4bb566cad7e54d28ea82fd11470c3ef121b47 (diff)
downloadbcm5719-llvm-ce45e39c24faddce0afa7024934ede455dc5206b.tar.gz
bcm5719-llvm-ce45e39c24faddce0afa7024934ede455dc5206b.zip
[CMake] Connect check-compiler-rt to check-all
When using the LLVM_BUILD_EXTERNAL_COMPILER_RT option with LLVM_ENABLE_TESTS we should also bind check-compiler-rt to check-all so that the compiler-rt tests run too. llvm-svn: 274045
Diffstat (limited to 'clang/runtime/CMakeLists.txt')
-rw-r--r--clang/runtime/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/clang/runtime/CMakeLists.txt b/clang/runtime/CMakeLists.txt
index 1c745ee2236..2f8056efcd5 100644
--- a/clang/runtime/CMakeLists.txt
+++ b/clang/runtime/CMakeLists.txt
@@ -141,6 +141,7 @@ if(LLVM_BUILD_EXTERNAL_COMPILER_RT AND EXISTS ${COMPILER_RT_SRC_ROOT}/)
COMMAND ${run_check_compiler_rt}
DEPENDS compiler-rt-build ${COMPILER_RT_TEST_DEPENDENCIES}
WORKING_DIRECTORY ${BINARY_DIR}
- VERBATIM)
+ VERBATIM USES_TERMINAL)
+ set_property(GLOBAL APPEND PROPERTY LLVM_LIT_DEPENDS check-compiler-rt)
endif()
endif()
OpenPOWER on IntegriCloud