summaryrefslogtreecommitdiffstats
path: root/clang/examples/AnnotateFunctions/CMakeLists.txt
diff options
context:
space:
mode:
authorJohn Brawn <john.brawn@arm.com>2016-07-27 11:18:38 +0000
committerJohn Brawn <john.brawn@arm.com>2016-07-27 11:18:38 +0000
commit63aff61019e0a6bdae4cfdac2a3cc0be9fdcfa97 (patch)
tree6cf40a21310a7cd814e0483a34bd509fac65219e /clang/examples/AnnotateFunctions/CMakeLists.txt
parent10bf0ff879fac0fb02f33907385e969acb9b1f24 (diff)
downloadbcm5719-llvm-63aff61019e0a6bdae4cfdac2a3cc0be9fdcfa97.tar.gz
bcm5719-llvm-63aff61019e0a6bdae4cfdac2a3cc0be9fdcfa97.zip
Adjust Registry interface to not require plugins to export a registry
Currently the Registry class contains the vestiges of a previous attempt to allow plugins to be used on Windows without using BUILD_SHARED_LIBS, where a plugin would have its own copy of a registry and export it to be imported by the tool that's loading the plugin. This only works if the plugin is entirely self-contained with the only interface between the plugin and tool being the registry, and in particular this conflicts with how IR pass plugins work. This patch changes things so that instead the add_node function of the registry is exported by the tool and then imported by the plugin, which solves this problem and also means that instead of every plugin having to export every registry they use instead LLVM only has to export the add_node functions. This allows plugins that use a registry to work on Windows if LLVM_EXPORT_SYMBOLS_FOR_PLUGINS is used. Differential Revision: http://reviews.llvm.org/D21385 llvm-svn: 276856
Diffstat (limited to 'clang/examples/AnnotateFunctions/CMakeLists.txt')
-rw-r--r--clang/examples/AnnotateFunctions/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/clang/examples/AnnotateFunctions/CMakeLists.txt b/clang/examples/AnnotateFunctions/CMakeLists.txt
index cf564d527d6..5684abf2380 100644
--- a/clang/examples/AnnotateFunctions/CMakeLists.txt
+++ b/clang/examples/AnnotateFunctions/CMakeLists.txt
@@ -1,4 +1,4 @@
-add_llvm_loadable_module(AnnotateFunctions AnnotateFunctions.cpp)
+add_llvm_loadable_module(AnnotateFunctions AnnotateFunctions.cpp PLUGIN_TOOL clang)
if(LLVM_ENABLE_PLUGINS AND (WIN32 OR CYGWIN))
target_link_libraries(AnnotateFunctions PRIVATE
OpenPOWER on IntegriCloud