summaryrefslogtreecommitdiffstats
path: root/clang/CMakeLists.txt
diff options
context:
space:
mode:
authorAlp Toker <alp@nuanti.com>2014-07-16 16:48:33 +0000
committerAlp Toker <alp@nuanti.com>2014-07-16 16:48:33 +0000
commit0621cb2e7dfd89f558a045f145f900b62379dcc2 (patch)
treefe7aa0e9718ccaa2199ec99044c72add529205d8 /clang/CMakeLists.txt
parentdb829de6d6a3dd4c13b0ee75ac35e42b7b92b7e6 (diff)
downloadbcm5719-llvm-0621cb2e7dfd89f558a045f145f900b62379dcc2.tar.gz
bcm5719-llvm-0621cb2e7dfd89f558a045f145f900b62379dcc2.zip
Make clang's rewrite engine a core feature
The rewrite facility's footprint is small so it's not worth going to these lengths to support disabling at configure time, particularly since key compiler features now depend on it. Meanwhile the Objective-C rewriters have been moved under the ENABLE_CLANG_ARCMT umbrella for now as they're comparatively heavy and still potentially worth excluding from lightweight builds. Tests are now passing with any combination of feature flags. The flags historically haven't been tested by LLVM's build servers so caveat emptor. llvm-svn: 213171
Diffstat (limited to 'clang/CMakeLists.txt')
-rw-r--r--clang/CMakeLists.txt19
1 files changed, 1 insertions, 18 deletions
diff --git a/clang/CMakeLists.txt b/clang/CMakeLists.txt
index b93a78ec01d..02374e20f43 100644
--- a/clang/CMakeLists.txt
+++ b/clang/CMakeLists.txt
@@ -391,13 +391,6 @@ else()
set(ENABLE_CLANG_ARCMT "0")
endif()
-option(CLANG_ENABLE_REWRITER "Build rewriter." ON)
-if (CLANG_ENABLE_REWRITER)
- set(ENABLE_CLANG_REWRITER "1")
-else()
- set(ENABLE_CLANG_REWRITER "0")
-endif()
-
option(CLANG_ENABLE_STATIC_ANALYZER "Build static analyzer." ON)
if (CLANG_ENABLE_STATIC_ANALYZER)
set(ENABLE_CLANG_STATIC_ANALYZER "1")
@@ -405,23 +398,13 @@ else()
set(ENABLE_CLANG_STATIC_ANALYZER "0")
endif()
-if (NOT CLANG_ENABLE_REWRITER AND CLANG_ENABLE_ARCMT)
- message(FATAL_ERROR "Cannot disable rewriter while enabling ARCMT")
-endif()
-
-if (NOT CLANG_ENABLE_REWRITER AND CLANG_ENABLE_STATIC_ANALYZER)
- message(FATAL_ERROR "Cannot disable rewriter while enabling static analyzer")
-endif()
-
if (NOT CLANG_ENABLE_STATIC_ANALYZER AND CLANG_ENABLE_ARCMT)
message(FATAL_ERROR "Cannot disable static analyzer while enabling ARCMT")
endif()
if(CLANG_ENABLE_ARCMT)
add_definitions(-DCLANG_ENABLE_ARCMT)
-endif()
-if(CLANG_ENABLE_REWRITER)
- add_definitions(-DCLANG_ENABLE_REWRITER)
+ add_definitions(-DCLANG_ENABLE_OBJC_REWRITER)
endif()
if(CLANG_ENABLE_STATIC_ANALYZER)
add_definitions(-DCLANG_ENABLE_STATIC_ANALYZER)
OpenPOWER on IntegriCloud