summaryrefslogtreecommitdiffstats
path: root/clang-tools-extra/CMakeLists.txt
diff options
context:
space:
mode:
authorPeter Collingbourne <peter@pcc.me.uk>2013-11-08 00:08:23 +0000
committerPeter Collingbourne <peter@pcc.me.uk>2013-11-08 00:08:23 +0000
commit8b1265b353b027d90252f1a23c5c3121ee70f3a1 (patch)
tree4d104d38960d01338209c32d106c9b6a764976e7 /clang-tools-extra/CMakeLists.txt
parent640830142100ea828ba54b42c68ccc4b3dd1d8ea (diff)
downloadbcm5719-llvm-8b1265b353b027d90252f1a23c5c3121ee70f3a1.tar.gz
bcm5719-llvm-8b1265b353b027d90252f1a23c5c3121ee70f3a1.zip
Introduce clang-query tool.
This tool is for interactive exploration of the Clang AST using AST matchers. It currently allows the user to enter a matcher at an interactive prompt and view the resulting bindings as diagnostics, AST pretty prints or AST dumps. Example session: $ cat foo.c void foo(void) {} $ clang-query foo.c -- clang-query> match functionDecl() Match #1: foo.c:1:1: note: "root" binds here void foo(void) {} ^~~~~~~~~~~~~~~~~ 1 match. Differential Revision: http://llvm-reviews.chandlerc.com/D2098 llvm-svn: 194227
Diffstat (limited to 'clang-tools-extra/CMakeLists.txt')
-rw-r--r--clang-tools-extra/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/clang-tools-extra/CMakeLists.txt b/clang-tools-extra/CMakeLists.txt
index 2425fa92e82..f477f2cfe1b 100644
--- a/clang-tools-extra/CMakeLists.txt
+++ b/clang-tools-extra/CMakeLists.txt
@@ -1,5 +1,8 @@
+check_library_exists(edit el_init "" HAVE_LIBEDIT)
+
add_subdirectory(clang-apply-replacements)
add_subdirectory(clang-modernize)
+add_subdirectory(clang-query)
add_subdirectory(clang-tidy)
add_subdirectory(modularize)
add_subdirectory(pp-trace)
OpenPOWER on IntegriCloud