summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPatrick Venture <venture@google.com>2019-01-15 12:11:02 -0800
committerPatrick Venture <venture@google.com>2019-01-15 12:45:15 -0800
commitce6b874b484e6e89c504fdf6178614b9079e99c9 (patch)
tree47a2509f34874e1a4543bb07336967022d4ff2df /configure.ac
parentccf235a8b7b2d4fd100f7671d8ddbaac77466dab (diff)
downloadphosphor-ipmi-flash-ce6b874b484e6e89c504fdf6178614b9079e99c9.tar.gz
phosphor-ipmi-flash-ce6b874b484e6e89c504fdf6178614b9079e99c9.zip
bugfix: build: fix MAPPED_ADDRESS configuration variable
Fix the MAPPED_ADDRESS configuration variable. Change-Id: I53a338868857f6654b46eb6522c74c63a022ef86 Signed-off-by: Patrick Venture <venture@google.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 117a3ed..b722ec1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -75,8 +75,8 @@ AS_IF([test "x$enable_lpc_bridge" = "xyes"], [
# for PCI, this address is passed back to the host and is used directly.
AC_ARG_VAR(MAPPED_ADDRESS, [The base address of the memory region reserved for mapping.])
AS_IF([test "x$MAPPED_ADDRESS" == "x"],
- [AC_DEFINE(MAPPED_ADDRESS, [0], [Default address to 0.])],
- [AC_DEFINE(MAPPED_ADDRESS, [$MAPPED_ADDRESS], [Value for memory region mapping.])]
+ [AC_DEFINE_UNQUOTED(MAPPED_ADDRESS, [0], [Default address to 0.])],
+ [AC_DEFINE_UNQUOTED(MAPPED_ADDRESS, [$MAPPED_ADDRESS], [Value for memory region mapping.])]
)
AC_ARG_ENABLE([aspeed-lpc],
OpenPOWER on IntegriCloud