summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/Config.in1
-rw-r--r--package/cppunit/Config.in14
-rw-r--r--package/cppunit/cppunit.hash5
-rw-r--r--package/cppunit/cppunit.mk14
4 files changed, 34 insertions, 0 deletions
diff --git a/package/Config.in b/package/Config.in
index 8be24f475b..5de4df9fef 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -101,6 +101,7 @@ menu "Development tools"
source "package/bison/Config.in"
source "package/bsdiff/Config.in"
source "package/bustle/Config.in"
+ source "package/cppunit/Config.in"
source "package/cvs/Config.in"
if BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
source "package/diffutils/Config.in"
diff --git a/package/cppunit/Config.in b/package/cppunit/Config.in
new file mode 100644
index 0000000000..d7582b3b6b
--- /dev/null
+++ b/package/cppunit/Config.in
@@ -0,0 +1,14 @@
+config BR2_PACKAGE_CPPUNIT
+ bool "cppunit"
+ depends on BR2_INSTALL_LIBSTDCPP
+ # currently the static situation is not correctly detected.
+ depends on !BR2_PREFER_STATIC_LIB
+ help
+ CppUnit is the C++ port of the famous JUnit framework for
+ unit testing. Test output is in XML or text format for
+ automatic testing and GUI based for supervised tests.
+
+ http://www.freedesktop.org/wiki/Software/cppunit/
+
+comment "cppunit needs a toolchain w/ C++, dynamic library"
+ depends on !BR2_INSTALL_LIBSTDCPP || BR2_PREFER_STATIC_LIB
diff --git a/package/cppunit/cppunit.hash b/package/cppunit/cppunit.hash
new file mode 100644
index 0000000000..a097e3256d
--- /dev/null
+++ b/package/cppunit/cppunit.hash
@@ -0,0 +1,5 @@
+# hash from: http://www.freedesktop.org/wiki/Software/cppunit/:
+md5 d1c6bdd5a76c66d2c38331e2d287bc01 cppunit-1.13.2.tar.gz
+
+# Locally calculated:
+sha512 8f4be569f321d577cec31931f49f4df143bc94e283605509b6ea50c60690aa91a2aed940e7eebd4b2413a4218f9a6c3978d312d8e587eab040283c6563846ecd cppunit-1.13.2.tar.gz
diff --git a/package/cppunit/cppunit.mk b/package/cppunit/cppunit.mk
new file mode 100644
index 0000000000..b8251c297a
--- /dev/null
+++ b/package/cppunit/cppunit.mk
@@ -0,0 +1,14 @@
+################################################################################
+#
+# cppunit
+#
+################################################################################
+
+CPPUNIT_VERSION = 1.13.2
+CPPUNIT_SITE = http://dev-www.libreoffice.org/src
+CPPUNIT_INSTALL_STAGING = YES
+CPPUNIT_LICENSE = LGPLv2.1
+CPPUNIT_LICENSE_FILES = COPYING
+CPPUNIT_CONF_OPTS = --disable-doxygen
+
+$(eval $(autotools-package))
OpenPOWER on IntegriCloud