summaryrefslogtreecommitdiffstats
path: root/test/urls/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/urls/Makefile.am')
-rw-r--r--test/urls/Makefile.am52
1 files changed, 52 insertions, 0 deletions
diff --git a/test/urls/Makefile.am b/test/urls/Makefile.am
new file mode 100644
index 0000000..9bb9569
--- /dev/null
+++ b/test/urls/Makefile.am
@@ -0,0 +1,52 @@
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; version 2 of the License.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+
+AUTOMAKE_OPTIONS = parallel-tests
+
+AM_CPPFLAGS = \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/lib \
+ -I$(includedir) \
+ $(DEFAULT_CPPFLAGS)
+
+AM_CFLAGS = \
+ $(DEFAULT_CFLAGS)
+
+parse_url_SOURCES = \
+ parse-url.c \
+ ../../ui/common/url.c \
+ ../../ui/common/url.h
+
+parse_url_LDADD = ../../lib/libpbcore.la
+
+check_PROGRAMS = parse-url
+check_SCRIPTS = run-url-test
+
+TESTS = data/double-slash.test \
+ data/http-simple.test
+TEST_EXTENSIONS = .test
+TEST_LOG_COMPILER = $(builddir)/run-url-test
+
+edit = sed \
+ -e 's|@PACKAGE_NAME\@|$(PACKAGE_NAME)|g' \
+ -e 's|@PACKAGE_VERSION\@|$(PACKAGE_VERSION)|g' \
+ -e 's|@PACKAGE_BUGREPORT\@|$(PACKAGE_BUGREPORT)|g' \
+ -e 's|@abs_srcdir\@|$(abs_srcdir)|g' \
+ -e 's|@abs_builddir\@|$(abs_builddir)|g' \
+ -e 's|@prefix\@|$(prefix)|g'
+
+run-url-test: Makefile $(srcdir)/run-url-test.in
+ rm -f $@ $@.tmp
+ $(edit) $(srcdir)/$@.in >$@.tmp
+ chmod +x $@.tmp
+ mv $@.tmp $@
OpenPOWER on IntegriCloud