summaryrefslogtreecommitdiffstats
path: root/test/parser/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/parser/Makefile.am')
-rw-r--r--test/parser/Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/test/parser/Makefile.am b/test/parser/Makefile.am
index aa4591f..2e97fbe 100644
--- a/test/parser/Makefile.am
+++ b/test/parser/Makefile.am
@@ -47,5 +47,15 @@ LDADD = $(common_libs) $(test_libs)
libtest_o_SOURCES = utils.c parser-test.h handler.c main.c $(parser_test_objs)
+$(check_PROGRAMS): %: %.embedded-config.o
+$(check_PROGRAMS): LDADD += $@.embedded-config.o
-EXTRA_DIST = $(check_DATA)
+extract_config = $(srcdir)/extract-config.awk
+
+%.embedded-config.c: %.c $(extract_config)
+ gawk --file=$(extract_config) $^ > $@
+
+EXTRA_DIST = $(check_DATA) $(extract_config)
+
+CLEANFILES = $(foreach f, $(check_PROGRAMS), \
+ $(f).embedded-config.c $(f).embedded-config.o)
OpenPOWER on IntegriCloud