summaryrefslogtreecommitdiffstats
path: root/test/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/lib/Makefile.am')
-rw-r--r--test/lib/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/test/lib/Makefile.am b/test/lib/Makefile.am
index 9636b08..047fcb2 100644
--- a/test/lib/Makefile.am
+++ b/test/lib/Makefile.am
@@ -25,7 +25,14 @@ lib_TESTS = \
test/lib/test-process-stdout-eintr \
test/lib/test-fold
+if WITH_OPENSSL
+lib_TESTS += \
+ test/lib/test-security-openssl-verify \
+ test/lib/test-security-openssl-decrypt
+endif
+
$(lib_TESTS): LIBS += $(core_lib)
+$(lib_TESTS): AM_CPPFLAGS += -DTEST_LIB_DATA_BASE='"$(abs_top_srcdir)/test/lib/data"'
check_PROGRAMS += $(lib_TESTS)
TESTS += $(lib_TESTS)
OpenPOWER on IntegriCloud