summaryrefslogtreecommitdiffstats
path: root/test/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/lib/Makefile.am')
-rw-r--r--test/lib/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/test/lib/Makefile.am b/test/lib/Makefile.am
new file mode 100644
index 0000000..56fea5e
--- /dev/null
+++ b/test/lib/Makefile.am
@@ -0,0 +1,30 @@
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; version 2 of the License.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+
+AUTOMAKE_OPTIONS = parallel-tests
+
+AM_CPPFLAGS = \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/lib \
+ -I$(includedir) \
+ $(DEFAULT_CPPFLAGS)
+
+AM_CFLAGS = \
+ $(DEFAULT_CFLAGS)
+
+list_test_SOURCES = list-test.c
+list_test_LDADD = ../../lib/libpbcore.la
+
+noinst_PROGRAMS = list-test
+
+MAINTAINERCLEANFILES = Makefile.in
OpenPOWER on IntegriCloud