summaryrefslogtreecommitdiffstats
path: root/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am35
1 files changed, 35 insertions, 0 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
new file mode 100644
index 0000000..7b3d50d
--- /dev/null
+++ b/lib/Makefile.am
@@ -0,0 +1,35 @@
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; version 2 of the License.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+#
+
+AM_CPPFLAGS = -I$(top_srcdir)/lib $(DEFAULT_CPPFLAGS)
+
+AM_CFLAGS = $(DEFAULT_CFLAGS)
+
+noinst_LTLIBRARIES = libpbcore.la
+
+libpbcore_la_SOURCES = \
+ log/log.h \
+ log/log.c \
+ list/list.c \
+ list/list.h \
+ waiter/waiter.c \
+ waiter/waiter.h \
+ pb-protocol/pb-protocol.c \
+ pb-protocol/pb-protocol.h \
+ talloc/talloc.c \
+ talloc/talloc.h \
+ system/system.c \
+ system/system.h
+
+MAINTAINERCLEANFILES = Makefile.in
OpenPOWER on IntegriCloud