summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am44
1 files changed, 41 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 7ae5012..15d561f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -12,17 +12,20 @@
# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
#
-AUTOMAKE_OPTIONS = foreign
+AUTOMAKE_OPTIONS = foreign subdir-objects parallel-tests
-SUBDIRS = lib discover test ui utils man po
+SUBDIRS = po
ACLOCAL_AMFLAGS = -I m4
-AM_CPPFLAGS = $(DEFAULT_CPPFLAGS)
+AM_CPPFLAGS = $(DEFAULT_CPPFLAGS) -I$(top_srcdir)/lib
AM_CFLAGS = $(DEFAULT_CFLAGS)
+AM_YFLAGS = -d
LIBTOOL_DEPS = @LIBTOOL_DEPS@
+pkgsysconfdir = @sysconfdir@/@PACKAGE@
+
libtool: $(LIBTOOL_DEPS)
$(SHELL) ./config.status libtool
@@ -33,3 +36,38 @@ MAINTAINERCLEANFILES = aclocal.m4 config.* configure configure.ac depcomp \
maintainer-clean-local:
rm -rf m4
+
+noinst_LTLIBRARIES =
+noinst_PROGRAMS =
+sbin_PROGRAMS =
+dist_sbin_SCRIPTS =
+check_PROGRAMS =
+check_DATA =
+check_SCRIPTS =
+TESTS =
+BUILT_SOURCES =
+CLEANFILES =
+
+include lib/Makefile.am
+include discover/grub2/Makefile.am
+include discover/Makefile.am
+include test/Makefile.am
+include test/lib/Makefile.am
+include test/parser/Makefile.am
+include test/urls/Makefile.am
+include ui/common/Makefile.am
+
+if WITH_NCURSES
+include ui/ncurses/Makefile.am
+endif
+
+if WITH_TWIN
+include ui/twin/Makefile.am
+endif
+
+include ui/test/Makefile.am
+
+include man/Makefile.am
+
+include utils/Makefile.am
+
OpenPOWER on IntegriCloud