summaryrefslogtreecommitdiffstats
path: root/ui/test/Makefile.am
diff options
context:
space:
mode:
authorJeremy Kerr <jk@ozlabs.org>2014-07-28 16:20:04 +0800
committerJeremy Kerr <jk@ozlabs.org>2014-08-01 11:24:26 +0800
commitc43847fe14e6b32cc58b8e8168f78e72ef94316d (patch)
tree4593c0e9d6adc4af40450a92aa4414109f9d29a4 /ui/test/Makefile.am
parent6c0dd46749cd791f3923e0d60f41d7a5e1033945 (diff)
downloadtalos-petitboot-c43847fe14e6b32cc58b8e8168f78e72ef94316d.tar.gz
talos-petitboot-c43847fe14e6b32cc58b8e8168f78e72ef94316d.zip
autotools: Use non-recursive make
With the current testing infrastructure, we don't have a strictly hierarchical set of dependencies. This causes problems with a recursive make, and means we have to hack around some of the dependencies. This change generates a single, top-level makefile from all of the Makefile.am fragments. We still need the po/ directory as a separate SUBDIR, but all others can be converted to non-recursive. Signed-off-by: Jeremy Kerr <jk@ozlabs.org>
Diffstat (limited to 'ui/test/Makefile.am')
-rw-r--r--ui/test/Makefile.am24
1 files changed, 6 insertions, 18 deletions
diff --git a/ui/test/Makefile.am b/ui/test/Makefile.am
index 63b7d8c..afdf301 100644
--- a/ui/test/Makefile.am
+++ b/ui/test/Makefile.am
@@ -11,22 +11,10 @@
# along with this program; if not, write to the Free Software
# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
#
+#
+noinst_PROGRAMS += ui/test/discover-test
-AM_CPPFLAGS = \
- -I$(top_srcdir) \
- -I$(top_srcdir)/lib \
- $(DEFAULT_CPPFLAGS)
-
-AM_CFLAGS = \
- $(DEFAULT_CFLAGS)
-
-common_libs = \
- $(top_builddir)/ui/common/libpbui.la \
- $(top_builddir)/lib/libpbcore.la
-
-noinst_PROGRAMS = discover-test
-
-discover_test_SOURCES = discover-test.c
-discover_test_LDADD = $(common_libs)
-
-MAINTAINERCLEANFILES = Makefile.in
+ui_test_discover_test_SOURCES = ui/test/discover-test.c
+ui_test_discover_test_LDADD = \
+ ui/common/libpbui.la \
+ $(core_lib)
OpenPOWER on IntegriCloud