summaryrefslogtreecommitdiffstats
path: root/ui/common/Makefile.am
diff options
context:
space:
mode:
authorJeremy Kerr <jk@ozlabs.org>2014-07-28 16:20:04 +0800
committerJeremy Kerr <jk@ozlabs.org>2014-08-01 11:24:26 +0800
commitc43847fe14e6b32cc58b8e8168f78e72ef94316d (patch)
tree4593c0e9d6adc4af40450a92aa4414109f9d29a4 /ui/common/Makefile.am
parent6c0dd46749cd791f3923e0d60f41d7a5e1033945 (diff)
downloadtalos-petitboot-c43847fe14e6b32cc58b8e8168f78e72ef94316d.tar.gz
talos-petitboot-c43847fe14e6b32cc58b8e8168f78e72ef94316d.zip
autotools: Use non-recursive make
With the current testing infrastructure, we don't have a strictly hierarchical set of dependencies. This causes problems with a recursive make, and means we have to hack around some of the dependencies. This change generates a single, top-level makefile from all of the Makefile.am fragments. We still need the po/ directory as a separate SUBDIR, but all others can be converted to non-recursive. Signed-off-by: Jeremy Kerr <jk@ozlabs.org>
Diffstat (limited to 'ui/common/Makefile.am')
-rw-r--r--ui/common/Makefile.am55
1 files changed, 23 insertions, 32 deletions
diff --git a/ui/common/Makefile.am b/ui/common/Makefile.am
index a7b2f0f..df6ea02 100644
--- a/ui/common/Makefile.am
+++ b/ui/common/Makefile.am
@@ -12,48 +12,39 @@
# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
#
-AM_CPPFLAGS = \
- -I$(top_srcdir) \
- -I$(top_srcdir)/lib \
- $(DEFAULT_CPPFLAGS)
-
-AM_CFLAGS = \
- $(DEFAULT_CFLAGS)
-
-noinst_LTLIBRARIES = libpbui.la
-
-libpbui_la_SOURCES = \
- discover-client.c \
- discover-client.h \
- joystick.c \
- joystick.h \
- timer.c \
- timer.h \
- ui-system.c \
- ui-system.h
+noinst_LTLIBRARIES += ui/common/libpbui.la
+
+ui_common_libpbui_la_SOURCES = \
+ ui/common/discover-client.c \
+ ui/common/discover-client.h \
+ ui/common/joystick.c \
+ ui/common/joystick.h \
+ ui/common/timer.c \
+ ui/common/timer.h \
+ ui/common/ui-system.c \
+ ui/common/ui-system.h
if ENABLE_PS3
-libpbui_la_SOURCES += \
- ps3.c \
- ps3.h
+ui_common_libpbui_la_SOURCES += \
+ ui/common/ps3.c \
+ ui/common/ps3.h
endif
artwork =
if WITH_TWIN
artwork += \
- $(srcdir)/artwork/background.jpg \
- $(srcdir)/artwork/COPYING-tux \
- $(srcdir)/artwork/tux.png \
- $(srcdir)/artwork/oxygen/applications-system.png \
- $(srcdir)/artwork/oxygen/configure.png \
- $(srcdir)/artwork/oxygen/COPYING-oxygen \
- $(srcdir)/artwork/oxygen/drive-harddisk.png \
- $(srcdir)/artwork/oxygen/network-wired.png \
- $(srcdir)/artwork/oxygen/utilities-terminal.png
+ $(srcdir)/ui/common/artwork/background.jpg \
+ $(srcdir)/ui/common/artwork/COPYING-tux \
+ $(srcdir)/ui/common/artwork/tux.png \
+ $(srcdir)/ui/common/artwork/oxygen/applications-system.png \
+ $(srcdir)/ui/common/artwork/oxygen/configure.png \
+ $(srcdir)/ui/common/artwork/oxygen/COPYING-oxygen \
+ $(srcdir)/ui/common/artwork/oxygen/drive-harddisk.png \
+ $(srcdir)/ui/common/artwork/oxygen/network-wired.png \
+ $(srcdir)/ui/common/artwork/oxygen/utilities-terminal.png
endif
artworkdir = $(pkgdatadir)/artwork/
dist_artwork_DATA = $(artwork)
-MAINTAINERCLEANFILES = Makefile.in
OpenPOWER on IntegriCloud