summaryrefslogtreecommitdiffstats
path: root/test/urls/Makefile.am
diff options
context:
space:
mode:
authorJeremy Kerr <jk@ozlabs.org>2014-07-28 16:20:04 +0800
committerJeremy Kerr <jk@ozlabs.org>2014-08-01 11:24:26 +0800
commitc43847fe14e6b32cc58b8e8168f78e72ef94316d (patch)
tree4593c0e9d6adc4af40450a92aa4414109f9d29a4 /test/urls/Makefile.am
parent6c0dd46749cd791f3923e0d60f41d7a5e1033945 (diff)
downloadtalos-petitboot-c43847fe14e6b32cc58b8e8168f78e72ef94316d.tar.gz
talos-petitboot-c43847fe14e6b32cc58b8e8168f78e72ef94316d.zip
autotools: Use non-recursive make
With the current testing infrastructure, we don't have a strictly hierarchical set of dependencies. This causes problems with a recursive make, and means we have to hack around some of the dependencies. This change generates a single, top-level makefile from all of the Makefile.am fragments. We still need the po/ directory as a separate SUBDIR, but all others can be converted to non-recursive. Signed-off-by: Jeremy Kerr <jk@ozlabs.org>
Diffstat (limited to 'test/urls/Makefile.am')
-rw-r--r--test/urls/Makefile.am45
1 files changed, 18 insertions, 27 deletions
diff --git a/test/urls/Makefile.am b/test/urls/Makefile.am
index fbdf792..47040ae 100644
--- a/test/urls/Makefile.am
+++ b/test/urls/Makefile.am
@@ -11,32 +11,24 @@
# along with this program; if not, write to the Free Software
# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
-AUTOMAKE_OPTIONS = parallel-tests
+check_PROGRAMS += test/urls/parse-url
+check_SCRIPTS += test/urls/run-url-test
-AM_CPPFLAGS = \
- -I$(top_srcdir) \
- -I$(top_srcdir)/lib \
- $(DEFAULT_CPPFLAGS)
+test_urls_parse_url_SOURCES = test/urls/parse-url.c
+test_urls_parse_url_LDADD = $(core_lib)
-AM_CFLAGS = \
- $(DEFAULT_CFLAGS)
+url_TESTS = \
+ test/urls/data/double-slash.test \
+ test/urls/data/http-simple.test \
+ test/urls/data/join-full.test \
+ test/urls/data/join-absolute.test \
+ test/urls/data/join-relative.test \
+ test/urls/data/localpath.test
-parse_url_SOURCES = parse-url.c
-
-parse_url_LDADD = ../../lib/libpbcore.la
-
-check_PROGRAMS = parse-url
-check_SCRIPTS = run-url-test
-
-TESTS = data/double-slash.test \
- data/http-simple.test \
- data/join-full.test \
- data/join-absolute.test \
- data/join-relative.test \
- data/localpath.test
+TESTS += $(url_TESTS)
TEST_EXTENSIONS = .test
-TEST_LOG_COMPILER = $(builddir)/run-url-test
+TEST_LOG_COMPILER = $(builddir)/test/urls/run-url-test
if ENABLE_TEST_VALGRIND
TEST_LOG_FLAGS = --valgrind
@@ -46,18 +38,17 @@ edit = sed \
-e 's|@PACKAGE_NAME\@|$(PACKAGE_NAME)|g' \
-e 's|@PACKAGE_VERSION\@|$(PACKAGE_VERSION)|g' \
-e 's|@PACKAGE_BUGREPORT\@|$(PACKAGE_BUGREPORT)|g' \
- -e 's|@abs_srcdir\@|$(abs_srcdir)|g' \
- -e 's|@abs_builddir\@|$(abs_builddir)|g' \
+ -e 's|@abs_srcdir\@|$(abs_srcdir)/test/urls|g' \
+ -e 's|@abs_builddir\@|$(abs_builddir)/test/urls|g' \
-e 's|@prefix\@|$(prefix)|g'
-EXTRA_DIST = $(TESTS) run-url-test.in
+EXTRA_DIST += $(url_TESTS) test/urls/run-url-test.in
-run-url-test: Makefile $(srcdir)/run-url-test.in
+test/urls/run-url-test: $(srcdir)/test/urls/run-url-test.in
rm -f $@ $@.tmp
$(edit) $(srcdir)/$@.in >$@.tmp
chmod +x $@.tmp
mv $@.tmp $@
-CLEANFILES = run-url-test
+CLEANFILES += test/urls/run-url-test
-MAINTAINERCLEANFILES = Makefile.in
OpenPOWER on IntegriCloud