summaryrefslogtreecommitdiffstats
path: root/test/parser/Makefile.am
diff options
context:
space:
mode:
authorJeremy Kerr <jk@ozlabs.org>2014-01-17 15:51:54 +0800
committerJeremy Kerr <jk@ozlabs.org>2014-01-17 17:01:47 +0800
commitf2acf9d2573ebbfb7478e97c4066c128ddaa5a18 (patch)
tree95f6ba125d82469e7329e6bd2c339480e3ec563d /test/parser/Makefile.am
parentd14bf38b9881c385478a460e3058d7cadee107fb (diff)
downloadtalos-petitboot-f2acf9d2573ebbfb7478e97c4066c128ddaa5a18.tar.gz
talos-petitboot-f2acf9d2573ebbfb7478e97c4066c128ddaa5a18.zip
discover: Support DHCP "pathprefix" configuration option
This change implements support for the DHCP "pathprefix" option. We use the following logic: - If pathprefix is present and a full URL, we base the config file location on pathprefix + conffile - If pathprefix is present but not a full URL, we use it as the path component of the URL, and pick up the host from other parameters in the DHCP response - If no pathprefix is present, we determine the configuration prefix from the DHCP bootfile parameter. Signed-off-by: Jeremy Kerr <jk@ozlabs.org>
Diffstat (limited to 'test/parser/Makefile.am')
-rw-r--r--test/parser/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/test/parser/Makefile.am b/test/parser/Makefile.am
index 47fd458..fdc53e3 100644
--- a/test/parser/Makefile.am
+++ b/test/parser/Makefile.am
@@ -62,6 +62,9 @@ TESTS = \
test-pxe-ip-without-conf \
test-pxe-non-url-conf \
test-pxe-local \
+ test-pxe-pathprefix-with-conf \
+ test-pxe-non-url-pathprefix-with-conf \
+ test-pxe-pathprefix-discover \
test-unresolved-remove
$(TESTS): %: %.embedded-config.o
OpenPOWER on IntegriCloud