summaryrefslogtreecommitdiffstats
path: root/test/parser/Makefile.am
diff options
context:
space:
mode:
authorGeoff Levand <geoff@infradead.org>2013-06-30 13:45:58 -0700
committerGeoff Levand <geoff@infradead.org>2013-06-30 13:45:58 -0700
commit434a6c9c100bc8daca1e6c41137f993d88f20fe3 (patch)
tree073d5f0aa428ac455de79fe839290723a3bf5e8a /test/parser/Makefile.am
parent203254ec7ca2352e898acc9ac5c971bcbf630720 (diff)
downloadtalos-petitboot-434a6c9c100bc8daca1e6c41137f993d88f20fe3.tar.gz
talos-petitboot-434a6c9c100bc8daca1e6c41137f993d88f20fe3.zip
discover: Fix automake warnings
Change the Makfile.am relocatable output files from automake _LIBRARIES to automake _PROGRAMS. Also, change the output file name extension from .o to .ro to better show these are relocatable files. Fixes automake warnings like these: discover/Makefile.am: `libparser.o' is not a standard library name discover/Makefile.am: did you mean `libparser.a'? Signed-off-by: Geoff Levand <geoff@infradead.org>
Diffstat (limited to 'test/parser/Makefile.am')
-rw-r--r--test/parser/Makefile.am9
1 files changed, 4 insertions, 5 deletions
diff --git a/test/parser/Makefile.am b/test/parser/Makefile.am
index e5c32cf..5dba679 100644
--- a/test/parser/Makefile.am
+++ b/test/parser/Makefile.am
@@ -23,7 +23,7 @@ AM_CPPFLAGS = \
AM_CFLAGS = -O0 -ggdb -Wall -Wextra -Werror
-LDADD = $(top_builddir)/lib/libpbcore.la libtest.o
+LDADD = $(top_builddir)/lib/libpbcore.la libtest.ro
TESTS = \
test-null \
@@ -54,18 +54,17 @@ parser_objs = \
$(top_srcdir)/discover/device-handler.c \
$(top_srcdir)/discover/parser-conf.c
-libtest_o_SOURCES = \
+libtest_ro_SOURCES = \
main.c \
utils.c \
handler.c \
parser-test.h \
$(parser_objs)
-libtest.o: $(libtest_o_OBJECTS)
+libtest.ro: $(libtest_ro_OBJECTS)
$(LD) -o $@ -r $^
-check_PROGRAMS = $(TESTS)
-check_LIBRARIES = libtest.o
+check_PROGRAMS = $(TESTS) libtest.ro
check_DATA = \
data/grub2-f18-ppc64.conf \
OpenPOWER on IntegriCloud