summaryrefslogtreecommitdiffstats
path: root/test/parser/Makefile.am
diff options
context:
space:
mode:
authorJeremy Kerr <jk@ozlabs.org>2014-12-01 11:47:16 +0800
committerJeremy Kerr <jk@ozlabs.org>2014-12-01 12:09:53 +0800
commit00a881a1adb6f656049939adecb9bf9edd29a658 (patch)
tree20fb132fd91c7ce718244ab9884efe0859e7eef0 /test/parser/Makefile.am
parent46fbb1e1e33b130284ec211f9c647268ff709ba7 (diff)
downloadtalos-petitboot-00a881a1adb6f656049939adecb9bf9edd29a658.tar.gz
talos-petitboot-00a881a1adb6f656049939adecb9bf9edd29a658.zip
discover/grub2: improve handling of word & delimiter tokens
Currently, the delimiter token handling is a little fragile: we try to ignore non-inter-word delimiters in the lexer with a selective set of regexes on the possible delimiter characters. This means we don't need to handle potential delimiters in every grammar rule, but there are other situations (not regex-able) where we may see delimters, and this will cause a parse error. Instead of relying on the regex behaviour, we have an 'inter_word' flag, which is set when we see the first word token, and cleared when we see an end-of-line token. We only emit TOKEN_DELIM when this flag is set. This means that we only get the delim tokens when they're required - when we're looking for word separators (becuase WORD DELIM WORD is distinct from WORD WORD - eg "linux /vmlinux" and "x$var"). We add a few new tests for the "menuentry" and "if" syntax, with different delimiter configurations. Signed-off-by: Jeremy Kerr <jk@ozlabs.org>
Diffstat (limited to 'test/parser/Makefile.am')
-rw-r--r--test/parser/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/test/parser/Makefile.am b/test/parser/Makefile.am
index eca4c0a..072eba6 100644
--- a/test/parser/Makefile.am
+++ b/test/parser/Makefile.am
@@ -16,6 +16,9 @@ parser_TESTS = \
test/parser/test-grub2-single \
test/parser/test-grub2-default \
test/parser/test-grub2-empty \
+ test/parser/test-grub2-noeol \
+ test/parser/test-grub2-menuentry-formats \
+ test/parser/test-grub2-if-formats \
test/parser/test-grub2-default-index \
test/parser/test-grub2-default-multiword \
test/parser/test-grub2-multiple-resolve \
OpenPOWER on IntegriCloud