summaryrefslogtreecommitdiffstats
path: root/test/lib/Makefile.am
diff options
context:
space:
mode:
authorBrett Grandbois <brett.grandbois@opengear.com>2018-05-15 10:55:52 +1000
committerSamuel Mendoza-Jonas <sam@mendozajonas.com>2018-05-30 14:23:47 +1000
commitd47114df83e88f1b5ae65747001fc13d5dae525b (patch)
tree7456849415ba5ea3631c90f781ca77c1765a65ba /test/lib/Makefile.am
parente370583366d72e55551f20e3f9b0457e787309bf (diff)
downloadtalos-petitboot-d47114df83e88f1b5ae65747001fc13d5dae525b.tar.gz
talos-petitboot-d47114df83e88f1b5ae65747001fc13d5dae525b.zip
test/lib: Add OpenSSL verify and decrypt tests
Signed-off-by: Brett Grandbois <brett.grandbois@opengear.com> Signed-off-by: Samuel Mendoza-Jonas <sam@mendozajonas.com>
Diffstat (limited to 'test/lib/Makefile.am')
-rw-r--r--test/lib/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/test/lib/Makefile.am b/test/lib/Makefile.am
index 9636b08..047fcb2 100644
--- a/test/lib/Makefile.am
+++ b/test/lib/Makefile.am
@@ -25,7 +25,14 @@ lib_TESTS = \
test/lib/test-process-stdout-eintr \
test/lib/test-fold
+if WITH_OPENSSL
+lib_TESTS += \
+ test/lib/test-security-openssl-verify \
+ test/lib/test-security-openssl-decrypt
+endif
+
$(lib_TESTS): LIBS += $(core_lib)
+$(lib_TESTS): AM_CPPFLAGS += -DTEST_LIB_DATA_BASE='"$(abs_top_srcdir)/test/lib/data"'
check_PROGRAMS += $(lib_TESTS)
TESTS += $(lib_TESTS)
OpenPOWER on IntegriCloud