summaryrefslogtreecommitdiffstats
path: root/test/lib/Makefile.am
diff options
context:
space:
mode:
authorJeremy Kerr <jk@ozlabs.org>2014-07-28 16:20:04 +0800
committerJeremy Kerr <jk@ozlabs.org>2014-08-01 11:24:26 +0800
commitc43847fe14e6b32cc58b8e8168f78e72ef94316d (patch)
tree4593c0e9d6adc4af40450a92aa4414109f9d29a4 /test/lib/Makefile.am
parent6c0dd46749cd791f3923e0d60f41d7a5e1033945 (diff)
downloadtalos-petitboot-c43847fe14e6b32cc58b8e8168f78e72ef94316d.tar.gz
talos-petitboot-c43847fe14e6b32cc58b8e8168f78e72ef94316d.zip
autotools: Use non-recursive make
With the current testing infrastructure, we don't have a strictly hierarchical set of dependencies. This causes problems with a recursive make, and means we have to hack around some of the dependencies. This change generates a single, top-level makefile from all of the Makefile.am fragments. We still need the po/ directory as a separate SUBDIR, but all others can be converted to non-recursive. Signed-off-by: Jeremy Kerr <jk@ozlabs.org>
Diffstat (limited to 'test/lib/Makefile.am')
-rw-r--r--test/lib/Makefile.am41
1 files changed, 16 insertions, 25 deletions
diff --git a/test/lib/Makefile.am b/test/lib/Makefile.am
index 23bee36..9636b08 100644
--- a/test/lib/Makefile.am
+++ b/test/lib/Makefile.am
@@ -11,30 +11,21 @@
# along with this program; if not, write to the Free Software
# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
-AUTOMAKE_OPTIONS = parallel-tests
+lib_TESTS = \
+ test/lib/list-test \
+ test/lib/test-process-noargs \
+ test/lib/test-process-sync \
+ test/lib/test-process-sync-stdout \
+ test/lib/test-process-stderr \
+ test/lib/test-process-stderr-stdout \
+ test/lib/test-process-async \
+ test/lib/test-process-async-stdout \
+ test/lib/test-process-parent-stdout \
+ test/lib/test-process-both \
+ test/lib/test-process-stdout-eintr \
+ test/lib/test-fold
-AM_CPPFLAGS = \
- -I$(top_srcdir) \
- -I$(top_srcdir)/lib \
- -DDEBUG
+$(lib_TESTS): LIBS += $(core_lib)
-AM_CFLAGS = -O0 -ggdb -Wall -Wextra -Werror
-
-LDADD = ../../lib/libpbcore.la
-
-check_PROGRAMS = list-test \
- test-process-noargs \
- test-process-sync \
- test-process-sync-stdout \
- test-process-stderr \
- test-process-stderr-stdout \
- test-process-async \
- test-process-async-stdout \
- test-process-parent-stdout \
- test-process-both \
- test-process-stdout-eintr \
- test-fold
-
-TESTS = $(check_PROGRAMS)
-
-MAINTAINERCLEANFILES = Makefile.in
+check_PROGRAMS += $(lib_TESTS)
+TESTS += $(lib_TESTS)
OpenPOWER on IntegriCloud