summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorJeremy Kerr <jk@ozlabs.org>2014-07-28 16:20:04 +0800
committerJeremy Kerr <jk@ozlabs.org>2014-08-01 11:24:26 +0800
commitc43847fe14e6b32cc58b8e8168f78e72ef94316d (patch)
tree4593c0e9d6adc4af40450a92aa4414109f9d29a4 /test/Makefile.am
parent6c0dd46749cd791f3923e0d60f41d7a5e1033945 (diff)
downloadtalos-petitboot-c43847fe14e6b32cc58b8e8168f78e72ef94316d.tar.gz
talos-petitboot-c43847fe14e6b32cc58b8e8168f78e72ef94316d.zip
autotools: Use non-recursive make
With the current testing infrastructure, we don't have a strictly hierarchical set of dependencies. This causes problems with a recursive make, and means we have to hack around some of the dependencies. This change generates a single, top-level makefile from all of the Makefile.am fragments. We still need the po/ directory as a separate SUBDIR, but all others can be converted to non-recursive. Signed-off-by: Jeremy Kerr <jk@ozlabs.org>
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am10
1 files changed, 4 insertions, 6 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 6562836..427041b 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -17,10 +17,8 @@ AM_LOG_FLAGS = --leak-check=full --error-exitcode=1
export LOG_COMPILER AM_LOG_FLAGS
endif
-SUBDIRS = lib parser urls
+noinst_SCRIPTS = test/hotplug-device.sh
+EXTRA_DIST += $(noinst_SCRIPTS)
-noinst_SCRIPTS = hotplug-device.sh
-
-EXTRA_DIST = $(noinst_SCRIPTS)
-
-MAINTAINERCLEANFILES = Makefile.in
+$(check_PROGRAMS): AM_CFLAGS = -O0 -g -Wall -Wextra -Werror
+$(check_PROGRAMS): AM_CPPFLAGS = -DDEBUG -I$(top_srcdir)/lib
OpenPOWER on IntegriCloud