summaryrefslogtreecommitdiffstats
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorJeremy Kerr <jk@ozlabs.org>2014-07-28 16:20:04 +0800
committerJeremy Kerr <jk@ozlabs.org>2014-08-01 11:24:26 +0800
commitc43847fe14e6b32cc58b8e8168f78e72ef94316d (patch)
tree4593c0e9d6adc4af40450a92aa4414109f9d29a4 /lib/Makefile.am
parent6c0dd46749cd791f3923e0d60f41d7a5e1033945 (diff)
downloadtalos-petitboot-c43847fe14e6b32cc58b8e8168f78e72ef94316d.tar.gz
talos-petitboot-c43847fe14e6b32cc58b8e8168f78e72ef94316d.zip
autotools: Use non-recursive make
With the current testing infrastructure, we don't have a strictly hierarchical set of dependencies. This causes problems with a recursive make, and means we have to hack around some of the dependencies. This change generates a single, top-level makefile from all of the Makefile.am fragments. We still need the po/ directory as a separate SUBDIR, but all others can be converted to non-recursive. Signed-off-by: Jeremy Kerr <jk@ozlabs.org>
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am61
1 files changed, 30 insertions, 31 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 5fc8911..f9f9461 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -12,38 +12,37 @@
# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
#
-AUTOMAKE_OPTIONS = subdir-objects
+core_lib = lib/libpbcore.la
-AM_CPPFLAGS = -I$(top_srcdir)/lib $(DEFAULT_CPPFLAGS) \
- -DPREFIX='"$(prefix)"'
-
-AM_CFLAGS = $(DEFAULT_CFLAGS)
+noinst_LTLIBRARIES += $(core_lib)
-noinst_LTLIBRARIES = libpbcore.la
+lib_libpbcore_la_CPPFLAGS = \
+ $(AM_CPPFLAGS) \
+ -DPREFIX='"$(prefix)"'
-libpbcore_la_SOURCES = \
- fold/fold.h \
- fold/fold.c \
- log/log.h \
- log/log.c \
- list/list.c \
- list/list.h \
- waiter/waiter.c \
- waiter/waiter.h \
- pb-protocol/pb-protocol.c \
- pb-protocol/pb-protocol.h \
- pb-config/pb-config.c \
- pb-config/pb-config.h \
- process/process.c \
- process/process.h \
- types/types.h \
- talloc/talloc.c \
- talloc/talloc.h \
- system/system.c \
- system/system.h \
- url/url.c \
- url/url.h \
- util/util.c \
- util/util.h
+lib_libpbcore_la_SOURCES = \
+ lib/fold/fold.h \
+ lib/fold/fold.c \
+ lib/i18n/i18n.h \
+ lib/log/log.h \
+ lib/log/log.c \
+ lib/list/list.c \
+ lib/list/list.h \
+ lib/waiter/waiter.c \
+ lib/waiter/waiter.h \
+ lib/pb-protocol/pb-protocol.c \
+ lib/pb-protocol/pb-protocol.h \
+ lib/pb-config/pb-config.c \
+ lib/pb-config/pb-config.h \
+ lib/process/process.c \
+ lib/process/process.h \
+ lib/types/types.h \
+ lib/talloc/talloc.c \
+ lib/talloc/talloc.h \
+ lib/system/system.c \
+ lib/system/system.h \
+ lib/url/url.c \
+ lib/url/url.h \
+ lib/util/util.c \
+ lib/util/util.h
-MAINTAINERCLEANFILES = Makefile.in
OpenPOWER on IntegriCloud