summaryrefslogtreecommitdiffstats
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorSamuel Mendoza-Jonas <sam.mj@au1.ibm.com>2015-12-15 10:02:31 +1100
committerSam Mendoza-Jonas <sam@mendozajonas.com>2016-02-09 13:40:15 +1100
commitaaeba8e515e6b3416718b7feac985f01fb948b8f (patch)
tree414a6a796682d2d2c9128e49f8c32e9b2a025617 /lib/Makefile.am
parent9239994cdedfc5dd70e3c5d27ea92754674aaa1f (diff)
downloadtalos-petitboot-aaeba8e515e6b3416718b7feac985f01fb948b8f.tar.gz
talos-petitboot-aaeba8e515e6b3416718b7feac985f01fb948b8f.zip
lib/flash: Add support for platform versions
Add basic libflash support to read the VERSION partition on BMC machines. This adds a dependency on the libflash shared library from Skiboot. The MTD partition is accessed through the libflash helper functions. Once read into a buffer, the VERSION partition is a simple list of newline-terminated version strings. Some BMC platforms may have two 'sides' to flash - these are interpreted as the "current" and "other" sides depending on which one the current Petitboot is running from. Signed-off-by: Sam Mendoza-Jonas <sam@mendozajonas.com>
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am19
1 files changed, 18 insertions, 1 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index a2421a5..a3ae943 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -48,4 +48,21 @@ lib_libpbcore_la_SOURCES = \
lib/url/url.c \
lib/url/url.h \
lib/util/util.c \
- lib/util/util.h
+ lib/util/util.h \
+ lib/flash/config.h \
+ lib/flash/flash.h
+
+if ENABLE_MTD
+lib_libpbcore_la_SOURCES += \
+ lib/flash/flash.c
+
+lib_libpbcore_la_CPPFLAGS += \
+ $(AM_CPPFLAGS)
+
+lib_libpbcore_la_LDFLAGS = \
+ $(AM_LDFLAGS) \
+ -l:libflash.so
+
+lib_libpbcore_la_SOURCES += \
+ lib/flash/flash.c
+endif
OpenPOWER on IntegriCloud