summaryrefslogtreecommitdiffstats
path: root/discover/grub2/Makefile.am
diff options
context:
space:
mode:
authorJeremy Kerr <jk@ozlabs.org>2013-09-16 15:12:13 +0800
committerJeremy Kerr <jk@ozlabs.org>2013-09-24 13:14:59 +0800
commit2ea5eb23b027519372dd20fbe8f958c06ac2aa6c (patch)
tree850a805d771be946d1cc28fbecabea0be6acf84c /discover/grub2/Makefile.am
parent5c6263a12dd7f859daa0feba8b58a0558f0ff21c (diff)
downloadtalos-petitboot-2ea5eb23b027519372dd20fbe8f958c06ac2aa6c.tar.gz
talos-petitboot-2ea5eb23b027519372dd20fbe8f958c06ac2aa6c.zip
discover/grub2: Hook up flex/bison parser to discover server
Signed-off-by: Jeremy Kerr <jk@ozlabs.org>
Diffstat (limited to 'discover/grub2/Makefile.am')
-rw-r--r--discover/grub2/Makefile.am48
1 files changed, 48 insertions, 0 deletions
diff --git a/discover/grub2/Makefile.am b/discover/grub2/Makefile.am
new file mode 100644
index 0000000..71f3282
--- /dev/null
+++ b/discover/grub2/Makefile.am
@@ -0,0 +1,48 @@
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; version 2 of the License.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+#
+
+AM_CPPFLAGS = -I$(top_srcdir)/lib -I$(top_srcdir) $(DEFAULT_CPPFLAGS)
+
+AM_CFLAGS = $(DEFAULT_CFLAGS) \
+ -DPREFIX='"$(prefix)"' \
+ -DPKG_SHARE_DIR='"$(pkgdatadir)"' \
+ -DPKG_SYSCONF_DIR='"$(pkgsysconfdir)"' \
+ -DLOCAL_STATE_DIR='"$(localstatedir)"'
+
+AM_YFLAGS = -d
+
+noinst_PROGRAMS = grub2-parser.ro
+
+grub2-parser.ro$(EXEEXT): $(grub2_parser_ro_OBJECTS)
+ $(LD) -r -o $@ $^
+
+
+grub2_parser_ro_SOURCES = \
+ builtins.c \
+ grub2.h \
+ grub2.c \
+ lexer.l \
+ parser.y \
+ script.c \
+ parser.c
+
+BUILT_SOURCES = parser.h lexer.h
+
+# ylwrap doesn't handle flex header files well; use our own rule here.
+lexer.h lexer.c: lexer.l
+ $(LEX) $(LFLAGS) --header-file=lexer.h -o lexer.c $^
+
+lexer.o: CFLAGS+=-Wno-unused-parameter -Wno-missing-prototypes \
+ -Wno-missing-declarations
+
OpenPOWER on IntegriCloud