summaryrefslogtreecommitdiffstats
path: root/discover/Makefile.am
diff options
context:
space:
mode:
authorGeoff Levand <geoff@infradead.org>2018-08-02 17:29:40 +0000
committerSamuel Mendoza-Jonas <sam@mendozajonas.com>2018-08-07 11:30:36 +1000
commit77f337931a96c33ff0ba66fb7f05891d520e8132 (patch)
tree973491fc73d61e914e10fcfc3fdfa6a1abc9710f /discover/Makefile.am
parentfed2c4da36c2708f2a5a7a09eba61d014b9339d6 (diff)
downloadtalos-petitboot-77f337931a96c33ff0ba66fb7f05891d520e8132.tar.gz
talos-petitboot-77f337931a96c33ff0ba66fb7f05891d520e8132.zip
configure: Add conditional platform builds
Add configure --enable-platform-XXX options to allow specifying which platform support to build. --enable-platform-auto, the default, will use the host triplet to guess which platforms to build. --enable-platform-all will build all platforms. Signed-off-by: Geoff Levand <geoff@infradead.org> Signed-off-by: Samuel Mendoza-Jonas <sam@mendozajonas.com>
Diffstat (limited to 'discover/Makefile.am')
-rw-r--r--discover/Makefile.am11
1 files changed, 7 insertions, 4 deletions
diff --git a/discover/Makefile.am b/discover/Makefile.am
index f9625ec..2b7c794 100644
--- a/discover/Makefile.am
+++ b/discover/Makefile.am
@@ -80,11 +80,11 @@ discover_platform_ro_SOURCES = \
discover/ipmi.h \
discover/dt.c \
discover/dt.h \
- discover/hostboot.h \
- discover/platform-powerpc.c
+ discover/hostboot.h
-discover_platform_ro_CPPFLAGS = \
- $(AM_CPPFLAGS)
+if PLATFORM_POWERPC
+discover_platform_ro_SOURCES += discover/platform-powerpc.c
+endif
# Build dummy last to put it at the end of the platforms section.
discover_platform_ro_SOURCES += discover/platform-dummy.c
@@ -99,5 +99,8 @@ discover_platform_ro_LDFLAGS = \
endif
+discover_platform_ro_CPPFLAGS = \
+ $(AM_CPPFLAGS)
+
discover_platform_ro_LINK = \
$(LD) -r -o $@
OpenPOWER on IntegriCloud