summaryrefslogtreecommitdiffstats
path: root/discover/Makefile.am
diff options
context:
space:
mode:
authorJoel Stanley <joel@jms.id.au>2015-04-21 16:17:57 +1000
committerJeremy Kerr <jk@ozlabs.org>2015-04-23 17:48:53 -0500
commit28219c8896177558892f48bef03ef7381382c420 (patch)
tree9b74311c1e7c1a6511fe5848165cec0e4e15c1b8 /discover/Makefile.am
parentf166fe2b62d781109e3a88736db96613af8c71d9 (diff)
downloadtalos-petitboot-28219c8896177558892f48bef03ef7381382c420.tar.gz
talos-petitboot-28219c8896177558892f48bef03ef7381382c420.zip
discover/platform-powerpc: Set IPMI OS boot sensor
This is to indicate to a BMC that we have initiated OS boot. This patch manually parses the device tree for the sensor information. In the future this could be replaced by libfdt or similar. Discover the id of your OS Boot sensor: $ sudo ipmitool sensor get "OS Boot" Locating sensor record... Sensor ID : OS Boot (0x5a) Entity ID : 35.0 (Operating System) Sensor Type (Discrete): OS Boot (0x1f) Sensor Reading : 0h Event Message Control : Per-threshold Assertion Events : OS Boot [boot completed - device not specified] Assertions Enabled : OS Boot [A: boot completed] [C: boot completed] [PXE boot completed] [Diagnostic boot completed] [CD-ROM boot completed] [ROM boot completed] [boot completed - device not specified] [Installation started] [Installation completed] [Installation aborted] [Installation failed] OEM : 0 In this case it is 0x1f. Note that the sesnor is currently asserted iwth boot completed - device not specified. Test by clearing all assertions in the OS Boot sensor: $ sudo ipmitool raw 0x04 0x30 0x5a 0x30 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 $ sudo ipmitool sensor get "OS Boot" Locating sensor record... Sensor ID : OS Boot (0x5a) Entity ID : 35.0 (Operating System) Sensor Type (Discrete): OS Boot (0x1f) Sensor Reading : 0h Event Message Control : Per-threshold Assertions Enabled : OS Boot [A: boot completed] [C: boot completed] [PXE boot completed] [Diagnostic boot completed] [CD-ROM boot completed] [ROM boot completed] [boot completed - device not specified] [Installation started] [Installation completed] [Installation aborted] [Installation failed] OEM : 0 Then reboot your system. The assertion event should once more say "boot completed - device not specified". Signed-off-by: Joel Stanley <joel@jms.id.au> Signed-off-by: Jeremy Kerr <jk@ozlabs.org>
Diffstat (limited to 'discover/Makefile.am')
-rw-r--r--discover/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/discover/Makefile.am b/discover/Makefile.am
index 1e4df0b..7808110 100644
--- a/discover/Makefile.am
+++ b/discover/Makefile.am
@@ -71,6 +71,8 @@ discover_platform_ro_SOURCES = \
discover/platform.h \
discover/ipmi.c \
discover/ipmi.h \
+ discover/dt.c \
+ discover/dt.h \
discover/platform-powerpc.c
discover_platform_ro_LINK = \
OpenPOWER on IntegriCloud