summaryrefslogtreecommitdiffstats
path: root/discover/Makefile.am
diff options
context:
space:
mode:
authorMaxiwell S. Garcia <maxiwell@linux.ibm.com>2019-09-23 19:30:22 -0300
committerJeremy Kerr <jk@ozlabs.org>2020-01-23 11:56:39 +0800
commit0c074025ef345c64af088c78c7f8f0e14a51f700 (patch)
tree49ad6fce71c87fed6500bd174ec20d262240c9e5 /discover/Makefile.am
parent827a7af51bb120579a7addbcda216300988a3b1e (diff)
downloadtalos-petitboot-0c074025ef345c64af088c78c7f8f0e14a51f700.tar.gz
talos-petitboot-0c074025ef345c64af088c78c7f8f0e14a51f700.zip
discover: Add helper functions to read ELF notes
The libelf has low level functions to access the ELF structures. This commit adds two external higher level functions: elf_open_image(): - Get the ELF structure from a binary; elf_getnote_desc() - Get the ELF note 'descriptor' using both namespace and ELF type. The definitions used in the 'elf.h' was taken from linux source code: - arch/powerpc/include/asm/elfnote.h - arch/powerpc/kernel/note.S Signed-off-by: Maxiwell S. Garcia <maxiwell@linux.ibm.com>
Diffstat (limited to 'discover/Makefile.am')
-rw-r--r--discover/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/discover/Makefile.am b/discover/Makefile.am
index e2d0e93..2339203 100644
--- a/discover/Makefile.am
+++ b/discover/Makefile.am
@@ -80,7 +80,9 @@ discover_platform_ro_SOURCES = \
discover/ipmi.h \
discover/dt.c \
discover/dt.h \
- discover/hostboot.h
+ discover/hostboot.h \
+ discover/elf.c \
+ discover/elf.h
if PLATFORM_ARM64
discover_platform_ro_SOURCES += discover/platform-arm64.c
OpenPOWER on IntegriCloud