summaryrefslogtreecommitdiffstats
path: root/discover/Makefile.am
diff options
context:
space:
mode:
authorSamuel Mendoza-Jonas <sam.mj@au1.ibm.com>2015-12-09 10:32:41 +1100
committerSam Mendoza-Jonas <sam@mendozajonas.com>2016-02-09 13:40:15 +1100
commitd974c3c39237c8e94bb3a51d3511d18dea01043e (patch)
treeb20a31ea0911c0d6cd1c6340620ecdf78ab9c0e6 /discover/Makefile.am
parentaaeba8e515e6b3416718b7feac985f01fb948b8f (diff)
downloadtalos-petitboot-d974c3c39237c8e94bb3a51d3511d18dea01043e.tar.gz
talos-petitboot-d974c3c39237c8e94bb3a51d3511d18dea01043e.zip
Display VERSION partition info on BMC machines
On supported platforms read the VERSION partition on startup and display the available versions strings in the System Information screen. This adds a skeleton hostboot.c to support possible additional BMC platform support. Signed-off-by: Sam Mendoza-Jonas <sam@mendozajonas.com>
Diffstat (limited to 'discover/Makefile.am')
-rw-r--r--discover/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/discover/Makefile.am b/discover/Makefile.am
index 1672035..f55f1cd 100644
--- a/discover/Makefile.am
+++ b/discover/Makefile.am
@@ -79,7 +79,21 @@ discover_platform_ro_SOURCES = \
discover/ipmi.h \
discover/dt.c \
discover/dt.h \
+ discover/hostboot.h \
discover/platform-powerpc.c
+discover_platform_ro_CPPFLAGS = \
+ $(AM_CPPFLAGS)
+
+if ENABLE_MTD
+discover_platform_ro_SOURCES += \
+ discover/hostboot.c
+
+discover_platform_ro_LDFLAGS = \
+ $(core_lib) \
+ $(UDEV_LIBS)
+
+endif
+
discover_platform_ro_LINK = \
$(LD) -r -o $@
OpenPOWER on IntegriCloud