summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorSamuel Mendoza-Jonas <sam@mendozajonas.com>2016-12-16 16:04:46 +1100
committerSamuel Mendoza-Jonas <sam@mendozajonas.com>2016-12-20 16:40:21 +1100
commitdadebc9010718645789009a0fddbc6447b07f1da (patch)
tree15e3dd6a47f0cb41425f8551f81cbe31b1d69327 /configure.ac
parent78819395e5aa0dbd0c484f7a2512fcf04b87bbf2 (diff)
downloadtalos-petitboot-dadebc9010718645789009a0fddbc6447b07f1da.tar.gz
talos-petitboot-dadebc9010718645789009a0fddbc6447b07f1da.zip
discover/paths: Parse Busybox progress information
Several busybox utilities (tftp and wget in particular) use a common format for progress bar output. Add a stdout callback that recognises this format and passes progress information to device_handler_status_download(). If Petitboot has been explicitly built with busybox support set busybox_progress_cb() as the default stdout callback for load_url_async(). Signed-off-by: Samuel Mendoza-Jonas <sam@mendozajonas.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 41560d1..1496054 100644
--- a/configure.ac
+++ b/configure.ac
@@ -242,7 +242,11 @@ AC_ARG_ENABLE(
[],
[enable_busybox=no]
)
-#AM_CONDITIONAL([ENABLE_BUSYBOX], [test "x$enable_busybox" = "xyes"])
+AM_CONDITIONAL([ENABLE_BUSYBOX], [test "x$enable_busybox" = "xyes"])
+AS_IF([test "x$enable_busybox" = "xyes"],
+ [AC_DEFINE(WITH_BUSYBOX, 1, [Busybox environment enabled])],
+ []
+)
AC_ARG_ENABLE(
[mtd],
OpenPOWER on IntegriCloud