summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGe Song <ge.song@hxt-semitech.com>2018-08-02 17:29:41 +0000
committerSamuel Mendoza-Jonas <sam@mendozajonas.com>2018-08-07 11:30:36 +1000
commitbf220b175df1f1689626598b286b817bc7749057 (patch)
tree8fa07b84f1294d65fd52ad33d7b95ef11687e960 /configure.ac
parentc8afffc32546c3cd72d5d229081211b8e9efe9ee (diff)
downloadtalos-petitboot-bf220b175df1f1689626598b286b817bc7749057.tar.gz
talos-petitboot-bf220b175df1f1689626598b286b817bc7749057.zip
discover: Add platform-arm64
Signed-off-by: Ge Song <ge.song@hxt-semitech.com> [Split from a larger patch and cleaned up] Signed-off-by: Geoff Levand <geoff@infradead.org> Signed-off-by: Samuel Mendoza-Jonas <sam@mendozajonas.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 11 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index eca574a..2bf6e6f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -313,7 +313,7 @@ AC_ARG_ENABLE(
)
AS_IF(
[test "x$enable_platform_all" = "xyes"],
- [enable_platform_powerpc="yes"; enable_platform_ps3="yes"]
+ [enable_platform_arm64="yes"; enable_platform_powerpc="yes"; enable_platform_ps3="yes"]
)
AC_ARG_ENABLE(
@@ -328,11 +328,21 @@ AC_ARG_ENABLE(
AS_IF(
[test "x$enable_platform_auto" = "xyes"],
[AS_CASE([$host],
+ [aarch64-*-*], [enable_platform_arm64="yes"],
[powerpc*-*-*], [enable_platform_powerpc="yes"],
)]
)
AC_ARG_ENABLE(
+ [platform-arm64],
+ [AS_HELP_STRING(
+ [--enable-platform-arm64],
+ [build support for arm64 platforms [default=no]]
+ )]
+)
+AM_CONDITIONAL([PLATFORM_ARM64], [test "x$enable_platform_arm64" = "xyes"])
+
+AC_ARG_ENABLE(
[platform-powerpc],
[AS_HELP_STRING(
[--enable-platform-powerpc],
OpenPOWER on IntegriCloud