summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGeoff Levand <geoffrey.levand@am.sony.com>2009-02-27 14:53:57 +0000
committerJeremy Kerr <jk@ozlabs.org>2009-03-23 21:47:55 +1100
commit91c81b32898c9ebf2386365b9f8ce1e405b166f8 (patch)
tree6d143f3288271c6a93dfa48bf5a39e544bc10382 /configure.ac
parent3ba31d4efc8e8d740ee0868fcf50aa51245571a5 (diff)
downloadtalos-petitboot-91c81b32898c9ebf2386365b9f8ce1e405b166f8.tar.gz
talos-petitboot-91c81b32898c9ebf2386365b9f8ce1e405b166f8.zip
Hookup the --with-twin configure option
Add some missing makefile parts to make the --with-twin configure option work properly. Signed-off-by: Geoff Levand <geoffrey.levand@am.sony.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 467104a..117c065 100644
--- a/configure.ac
+++ b/configure.ac
@@ -35,6 +35,7 @@ AC_ARG_WITH([twin],
[],
[with_twin=check])
+PBTWIN=
LIBTWIN=
AS_IF([test "x$with_twin" != xno],
[PKG_CHECK_MODULES([twin], [libtwin], [],
@@ -42,13 +43,13 @@ AS_IF([test "x$with_twin" != xno],
AC_MSG_RESULT([Consider adjusting PKG_CONFIG_PATH environment variable])])
AC_CHECK_LIB([twin], [main],
[AC_SUBST([LIBTWIN], ["-ltwin"])
+ AC_SUBST([PBTWIN], ["y"])
AC_DEFINE([HAVE_LIBTWIN], [1], [Define if you have libtwin])],
[if test "x$with_twin" != xcheck; then
AC_MSG_FAILURE([--with-twin was given, but test for twin failed])
fi],
[${twin_LIBS}])])
-
mkdir -p discover ui/test ui/common lib/talloc lib/pb-protocol lib/list \
lib/waiter lib/log
OpenPOWER on IntegriCloud