summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJeremy Kerr <jk@ozlabs.org>2008-12-09 17:48:45 +1100
committerJeremy Kerr <jk@ozlabs.org>2008-12-09 17:48:45 +1100
commit000a92b4fa909c432732ac3ed8f28eeeaeac70ee (patch)
tree4959271e593b116ef37d66e6b8dcf11652600c3e /configure.ac
parente518d1d16c16781d6824ece2ee0ddd1ac2339703 (diff)
downloadtalos-petitboot-000a92b4fa909c432732ac3ed8f28eeeaeac70ee.tar.gz
talos-petitboot-000a92b4fa909c432732ac3ed8f28eeeaeac70ee.zip
autoconfiscate
Add autoconf, but keep non-recursive Makefile structure. Signed-off-by: Jeremy Kerr <jk@ozlabs.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac35
1 files changed, 35 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..5ef5aa0
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,35 @@
+## configure.ac -- Process this file with autoconf to produce configure
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; version 2 of the License.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+#
+
+AC_INIT([petitboot], [0.2], [Jeremy Kerr <jk@ozlabs.org>])
+
+AC_CONFIG_HEADERS([config.h])
+AC_CONFIG_FILES([Makefile])
+
+default_CFLAGS='--std=gnu99 -O2 -Wall -g'
+
+if test "x$CFLAGS" = "x"; then
+ CFLAGS="$default_CFLAGS"
+fi
+
+AC_PROG_CC
+AC_PROG_INSTALL
+
+PKG_CHECK_MODULES([twin], [libtwin])
+
+mkdir devices
+
+AC_OUTPUT
OpenPOWER on IntegriCloud