summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGeoff Levand <geoff@infradead.org>2011-11-12 14:16:05 -0800
committerGeoff Levand <geoff@infradead.org>2011-11-12 14:17:35 -0800
commit8dbd2fe3c33cebdc20315dee7084a137e5843184 (patch)
tree48250b6493e2ccab692ba363e73771309c6de931 /configure.ac
parentc75e362781057bc982799d300eebfd47417ad23e (diff)
downloadtalos-petitboot-8dbd2fe3c33cebdc20315dee7084a137e5843184.tar.gz
talos-petitboot-8dbd2fe3c33cebdc20315dee7084a137e5843184.zip
Add twin checks to configure
Signed-off-by: Geoff Levand <geoff@infradead.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 12 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d123556..7582071 100644
--- a/configure.ac
+++ b/configure.ac
@@ -81,7 +81,18 @@ AS_IF([test "x$with_twin" != xno],
[if test "x$with_twin" != xcheck; then
AC_MSG_FAILURE([--with-twin was given, but test for twin failed])
fi],
- [${twin_LIBS}])])
+ [${twin_LIBS}])
+ AC_CHECK_HEADERS([libtwin/twin_x11.h])
+ AC_CHECK_HEADERS([libtwin/twin_fbdev.h])])
+
+AC_ARG_ENABLE([x11],
+ [AS_HELP_STRING([--enable-x11],
+ [build for x11])],
+ [],
+ [enable_x11=check])
+
+AS_IF([test "x$enable_x11" != xno], [AC_SUBST([ENABLE_X11], ["y"])], [])
+
mkdir -p discover lib/list lib/log lib/pb-protocol lib/system lib/talloc \
lib/waiter test ui/common ui/ncurses ui/test ui/twin utils
OpenPOWER on IntegriCloud