summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorSam Mendoza-Jonas <sam@mendozajonas.com>2015-12-22 10:39:28 +0800
committerSam Mendoza-Jonas <sam@mendozajonas.com>2016-02-25 16:20:30 +1100
commit91ba67605de8ff5f15c335db4330594e07b5317e (patch)
tree0bb4e529257f29c3265fca958bd3e6de3b9c61a9 /configure.ac
parent7460bbb60ff7070c6884b700fc6370cd58703c4b (diff)
downloadtalos-petitboot-91ba67605de8ff5f15c335db4330594e07b5317e.tar.gz
talos-petitboot-91ba67605de8ff5f15c335db4330594e07b5317e.zip
utils/hooks: Write offb device address to device tree
On OpenPOWER machines, kernels missing the AST video driver can use the existing 'Open Firmware' framebuffer device code to inherit an existing framebuffer from Petitboot. This requires us to translate the 64-bit address of the framebuffer 'back' into a PCI address and write it into an assigned-addresses property in the device tree. Bootstrapped-by: Jeremy Kerr <jk@ozlabs.org> Signed-off-by: Sam Mendoza-Jonas <sam@mendozajonas.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c9f587e..08685ec 100644
--- a/configure.ac
+++ b/configure.ac
@@ -57,6 +57,16 @@ AC_CHECK_LIB([udev], [udev_new],
[AC_MSG_FAILURE([The libudev development library is required by petitboot. Try installing the package libudev-dev or libudev-devel.])]
)
+AC_ARG_WITH([fdt],
+ AS_HELP_STRING([--without-fdt],
+ [Build without libfdt (default: no)]))
+
+AS_IF([test "x$with_fdt" != "xno"],
+ AC_CHECK_LIB([fdt], [fdt_check_header],
+ [FDT_LIBS=-lfdt; have_libfdt=yes]))
+
+AM_CONDITIONAL([HAVE_LIBFDT], [test x"$have_libfdt" = xyes])
+
AC_CHECK_HEADERS([stdarg.h])
AC_CHECK_HEADERS([varargs.h])
@@ -275,6 +285,7 @@ AS_IF(
)
AC_SUBST([UDEV_LIBS])
+AC_SUBST([FDT_LIBS])
AC_SUBST([LIBTOOL_DEPS])
AC_SUBST([DESTDIR])
AC_SUBST([pkgsysconfdir], ["${sysconfdir}/${package}"])
OpenPOWER on IntegriCloud