summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJeremy Kerr <jk@ozlabs.org>2014-07-28 16:20:04 +0800
committerJeremy Kerr <jk@ozlabs.org>2014-08-01 11:24:26 +0800
commitc43847fe14e6b32cc58b8e8168f78e72ef94316d (patch)
tree4593c0e9d6adc4af40450a92aa4414109f9d29a4 /Makefile.am
parent6c0dd46749cd791f3923e0d60f41d7a5e1033945 (diff)
downloadtalos-petitboot-c43847fe14e6b32cc58b8e8168f78e72ef94316d.tar.gz
talos-petitboot-c43847fe14e6b32cc58b8e8168f78e72ef94316d.zip
autotools: Use non-recursive make
With the current testing infrastructure, we don't have a strictly hierarchical set of dependencies. This causes problems with a recursive make, and means we have to hack around some of the dependencies. This change generates a single, top-level makefile from all of the Makefile.am fragments. We still need the po/ directory as a separate SUBDIR, but all others can be converted to non-recursive. Signed-off-by: Jeremy Kerr <jk@ozlabs.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am44
1 files changed, 41 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 7ae5012..15d561f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -12,17 +12,20 @@
# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
#
-AUTOMAKE_OPTIONS = foreign
+AUTOMAKE_OPTIONS = foreign subdir-objects parallel-tests
-SUBDIRS = lib discover test ui utils man po
+SUBDIRS = po
ACLOCAL_AMFLAGS = -I m4
-AM_CPPFLAGS = $(DEFAULT_CPPFLAGS)
+AM_CPPFLAGS = $(DEFAULT_CPPFLAGS) -I$(top_srcdir)/lib
AM_CFLAGS = $(DEFAULT_CFLAGS)
+AM_YFLAGS = -d
LIBTOOL_DEPS = @LIBTOOL_DEPS@
+pkgsysconfdir = @sysconfdir@/@PACKAGE@
+
libtool: $(LIBTOOL_DEPS)
$(SHELL) ./config.status libtool
@@ -33,3 +36,38 @@ MAINTAINERCLEANFILES = aclocal.m4 config.* configure configure.ac depcomp \
maintainer-clean-local:
rm -rf m4
+
+noinst_LTLIBRARIES =
+noinst_PROGRAMS =
+sbin_PROGRAMS =
+dist_sbin_SCRIPTS =
+check_PROGRAMS =
+check_DATA =
+check_SCRIPTS =
+TESTS =
+BUILT_SOURCES =
+CLEANFILES =
+
+include lib/Makefile.am
+include discover/grub2/Makefile.am
+include discover/Makefile.am
+include test/Makefile.am
+include test/lib/Makefile.am
+include test/parser/Makefile.am
+include test/urls/Makefile.am
+include ui/common/Makefile.am
+
+if WITH_NCURSES
+include ui/ncurses/Makefile.am
+endif
+
+if WITH_TWIN
+include ui/twin/Makefile.am
+endif
+
+include ui/test/Makefile.am
+
+include man/Makefile.am
+
+include utils/Makefile.am
+
OpenPOWER on IntegriCloud