summaryrefslogtreecommitdiffstats
path: root/yocto-poky/meta-skeleton/recipes-skeleton
diff options
context:
space:
mode:
Diffstat (limited to 'yocto-poky/meta-skeleton/recipes-skeleton')
-rw-r--r--yocto-poky/meta-skeleton/recipes-skeleton/service/service/COPYRIGHT15
-rw-r--r--yocto-poky/meta-skeleton/recipes-skeleton/service/service/skeleton193
-rw-r--r--yocto-poky/meta-skeleton/recipes-skeleton/service/service/skeleton_test.c12
-rw-r--r--yocto-poky/meta-skeleton/recipes-skeleton/service/service_0.1.bb31
-rw-r--r--yocto-poky/meta-skeleton/recipes-skeleton/useradd/useradd-example.bb76
-rw-r--r--yocto-poky/meta-skeleton/recipes-skeleton/useradd/useradd-example/file10
-rw-r--r--yocto-poky/meta-skeleton/recipes-skeleton/useradd/useradd-example/file20
-rw-r--r--yocto-poky/meta-skeleton/recipes-skeleton/useradd/useradd-example/file30
-rw-r--r--yocto-poky/meta-skeleton/recipes-skeleton/useradd/useradd-example/file40
9 files changed, 0 insertions, 327 deletions
diff --git a/yocto-poky/meta-skeleton/recipes-skeleton/service/service/COPYRIGHT b/yocto-poky/meta-skeleton/recipes-skeleton/service/service/COPYRIGHT
deleted file mode 100644
index ec3e17113..000000000
--- a/yocto-poky/meta-skeleton/recipes-skeleton/service/service/COPYRIGHT
+++ /dev/null
@@ -1,15 +0,0 @@
-Sysvinit is Copyright (C) 1991-2004 Miquel van Smoorenburg
-
- This program is free software; you can redistribute it and/or modify
- it under the terms of the GNU General Public License as published by
- the Free Software Foundation; either version 2 of the License, or
- (at your option) any later version.
-
- This program is distributed in the hope that it will be useful,
- but WITHOUT ANY WARRANTY; without even the implied warranty of
- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- GNU General Public License for more details.
-
- You should have received a copy of the GNU General Public License
- along with this program; if not, write to the Free Software
- Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
diff --git a/yocto-poky/meta-skeleton/recipes-skeleton/service/service/skeleton b/yocto-poky/meta-skeleton/recipes-skeleton/service/service/skeleton
deleted file mode 100644
index a3edc9d08..000000000
--- a/yocto-poky/meta-skeleton/recipes-skeleton/service/service/skeleton
+++ /dev/null
@@ -1,193 +0,0 @@
-#! /bin/sh
-### BEGIN INIT INFO
-# Provides: skeleton
-# Required-Start: $local_fs
-# Should-Start:
-# Required-Stop: $local_fs
-# Should-Stop:
-# Default-Start: 2 3 4 5
-# Default-Stop: 0 1 6
-# Short-Description: Example initscript
-# Description: This file should be used to construct scripts to be
-# placed in /etc/init.d
-### END INIT INFO
-
-# The definition of actions: (From LSB 3.1.0)
-# start start the service
-# stop stop the service
-# restart stop and restart the service if the service is already running,
-# otherwise start the service
-# try-restart restart the service if the service is already running
-# reload cause the configuration of the service to be reloaded without
-# actually stopping and restarting the service
-# force-reload cause the configuration to be reloaded if the service supports
-# this, otherwise restart the service if it is running
-# status print the current status of the service
-
-# The start, stop, restart, force-reload, and status actions shall be supported
-# by all init scripts; the reload and the try-restart actions are optional
-
-# Common steps to convert this skeleton into a real init script
-# 1) cp skeleton <the_real_name>
-# 2) Set DESC and NAME
-# 3) Check whether the daemon app is /usr/sbin/$NAME, if not, set it.
-# 4) Set DAEMON_ARGS if there is any
-# 5) Remove the useless code
-
-# NOTE: The skeleton doesn't support the daemon which is a script unless the
-# pidof supports "-x" option, please see more comments for pidofproc ()
-# in /etc/init.d/functions
-
-# PATH should only include /usr/* if it runs after the mountnfs.sh script
-PATH=/sbin:/usr/sbin:/bin:/usr/bin
-
-DESC="skeleton"
-NAME="skeleton-test"
-DAEMON=/usr/sbin/$NAME
-DAEMON_ARGS=""
-PIDFILE=/var/run/$NAME.pid
-
-. /etc/init.d/functions || exit 1
-
-# Exit if the package is not installed
-[ -x "$DAEMON" ] || exit 0
-
-# Read configuration variable file if it is present
-[ -r /etc/default/$NAME ] && . /etc/default/$NAME
-
-#
-# Function that starts the daemon/service
-#
-do_start() {
- local status pid
-
- status=0
- pid=`pidofproc $NAME` || status=$?
- case $status in
- 0)
- echo "$DESC already running ($pid)."
- exit 1
- ;;
- *)
- echo "Starting $DESC ..."
- exec $DAEMON $DAEMON_ARGS >/dev/null 2>&1 || status=$?
- echo "ERROR: Failed to start $DESC."
- exit $status
- ;;
- esac
-
- # Add code here, if necessary, that waits for the process to be ready
- # to handle requests from services started subsequently which depend
- # on this one. As a last resort, sleep for some time.
-}
-
-#
-# Function that stops the daemon/service
-#
-do_stop() {
- local pid status
-
- status=0
- pid=`pidofproc $NAME` || status=$?
- case $status in
- 0)
- # Exit when fail to stop, the kill would complain when fail
- kill -s 15 $pid >/dev/null && rm -f $PIDFILE && \
- echo "Stopped $DESC ($pid)." || exit $?
- ;;
- *)
- echo "$DESC is not running; none killed." >&2
- ;;
- esac
-
- # Wait for children to finish too if this is a daemon that forks
- # and if the daemon is only ever run from this initscript.
- # If the above conditions are not satisfied then add some other code
- # that waits for the process to drop all resources that could be
- # needed by services started subsequently. A last resort is to
- # sleep for some time.
- return $status
-}
-
-#
-# Function that sends a SIGHUP to the daemon/service
-#
-do_reload() {
- local pid status
-
- status=0
- # If the daemon can reload its configuration without
- # restarting (for example, when it is sent a SIGHUP),
- # then implement that here.
- pid=`pidofproc $NAME` || status=$?
- case $status in
- 0)
- echo "Reloading $DESC ..."
- kill -s 1 $pid || exit $?
- ;;
- *)
- echo "$DESC is not running; none reloaded." >&2
- ;;
- esac
- exit $status
-}
-
-
-#
-# Function that shows the daemon/service status
-#
-status_of_proc () {
- local pid status
-
- status=0
- # pidof output null when no program is running, so no "2>/dev/null".
- pid=`pidofproc $NAME` || status=$?
- case $status in
- 0)
- echo "$DESC is running ($pid)."
- exit 0
- ;;
- *)
- echo "$DESC is not running." >&2
- exit $status
- ;;
- esac
-}
-
-case "$1" in
-start)
- do_start
- ;;
-stop)
- do_stop || exit $?
- ;;
-status)
- status_of_proc
- ;;
-restart)
- # Always start the service regardless the status of do_stop
- do_stop
- do_start
- ;;
-try-restart|force-reload)
- # force-reload is the same as reload or try-restart according
- # to its definition, the reload is not implemented here, so
- # force-reload is the alias of try-restart here, but it should
- # be the alias of reload if reload is implemented.
- #
- # Only start the service when do_stop succeeds
- do_stop && do_start
- ;;
-#reload)
- # If the "reload" action is implemented properly, then let the
- # force-reload be the alias of reload, and remove it from
- # try-restart|force-reload)
- #
- #do_reload
- #;;
-*)
- echo "Usage: $0 {start|stop|status|restart|try-restart|force-reload}" >&2
- exit 3
- ;;
-esac
-
diff --git a/yocto-poky/meta-skeleton/recipes-skeleton/service/service/skeleton_test.c b/yocto-poky/meta-skeleton/recipes-skeleton/service/service/skeleton_test.c
deleted file mode 100644
index 96c67ac11..000000000
--- a/yocto-poky/meta-skeleton/recipes-skeleton/service/service/skeleton_test.c
+++ /dev/null
@@ -1,12 +0,0 @@
-#include <unistd.h>
-
-/* This demo does nothing except for testing /etc/init.d/skeleton */
-
-int main(int argc, char *argv[])
-{
- daemon(0, 0);
- while (1) {
- sleep(1);
- }
- return 0;
-}
diff --git a/yocto-poky/meta-skeleton/recipes-skeleton/service/service_0.1.bb b/yocto-poky/meta-skeleton/recipes-skeleton/service/service_0.1.bb
deleted file mode 100644
index c5cd7a97b..000000000
--- a/yocto-poky/meta-skeleton/recipes-skeleton/service/service_0.1.bb
+++ /dev/null
@@ -1,31 +0,0 @@
-SUMMARY = "The canonical example of init scripts"
-SECTION = "base"
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://${WORKDIR}/COPYRIGHT;md5=349c872e0066155e1818b786938876a4"
-
-SRC_URI = "file://skeleton \
- file://skeleton_test.c \
- file://COPYRIGHT \
- "
-
-do_compile () {
- ${CC} ${WORKDIR}/skeleton_test.c -o ${WORKDIR}/skeleton-test
-}
-
-do_install () {
- install -d ${D}${sysconfdir}/init.d
- cat ${WORKDIR}/skeleton | \
- sed -e 's,/etc,${sysconfdir},g' \
- -e 's,/usr/sbin,${sbindir},g' \
- -e 's,/var,${localstatedir},g' \
- -e 's,/usr/bin,${bindir},g' \
- -e 's,/usr,${prefix},g' > ${D}${sysconfdir}/init.d/skeleton
- chmod a+x ${D}${sysconfdir}/init.d/skeleton
-
- install -d ${D}${sbindir}
- install -m 0755 ${WORKDIR}/skeleton-test ${D}${sbindir}/
-}
-
-RDEPENDS_${PN} = "initscripts"
-
-CONFFILES_${PN} += "${sysconfdir}/init.d/skeleton"
diff --git a/yocto-poky/meta-skeleton/recipes-skeleton/useradd/useradd-example.bb b/yocto-poky/meta-skeleton/recipes-skeleton/useradd/useradd-example.bb
deleted file mode 100644
index d3c02d5d6..000000000
--- a/yocto-poky/meta-skeleton/recipes-skeleton/useradd/useradd-example.bb
+++ /dev/null
@@ -1,76 +0,0 @@
-SUMMARY = "Example recipe for using inherit useradd"
-DESCRIPTION = "This recipe serves as an example for using features from useradd.bbclass"
-SECTION = "examples"
-PR = "r1"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690 \
- file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
-
-SRC_URI = "file://file1 \
- file://file2 \
- file://file3 \
- file://file4"
-
-S = "${WORKDIR}"
-
-PACKAGES =+ "${PN}-user3"
-
-inherit useradd
-
-# You must set USERADD_PACKAGES when you inherit useradd. This
-# lists which output packages will include the user/group
-# creation code.
-USERADD_PACKAGES = "${PN} ${PN}-user3"
-
-# You must also set USERADD_PARAM and/or GROUPADD_PARAM when
-# you inherit useradd.
-
-# USERADD_PARAM specifies command line options to pass to the
-# useradd command. Multiple users can be created by separating
-# the commands with a semicolon. Here we'll create two users,
-# user1 and user2:
-USERADD_PARAM_${PN} = "-u 1200 -d /home/user1 -r -s /bin/bash user1; -u 1201 -d /home/user2 -r -s /bin/bash user2"
-
-# user3 will be managed in the useradd-example-user3 pacakge:
-# As an example, we use the -P option to set clear text password for user3
-USERADD_PARAM_${PN}-user3 = "-u 1202 -d /home/user3 -r -s /bin/bash -P 'user3' user3"
-
-# GROUPADD_PARAM works the same way, which you set to the options
-# you'd normally pass to the groupadd command. This will create
-# groups group1 and group2:
-GROUPADD_PARAM_${PN} = "-g 880 group1; -g 890 group2"
-
-# Likewise, we'll manage group3 in the useradd-example-user3 package:
-GROUPADD_PARAM_${PN}-user3 = "-g 900 group3"
-
-do_install () {
- install -d -m 755 ${D}${datadir}/user1
- install -d -m 755 ${D}${datadir}/user2
- install -d -m 755 ${D}${datadir}/user3
-
- install -p -m 644 file1 ${D}${datadir}/user1/
- install -p -m 644 file2 ${D}${datadir}/user1/
-
- install -p -m 644 file2 ${D}${datadir}/user2/
- install -p -m 644 file3 ${D}${datadir}/user2/
-
- install -p -m 644 file3 ${D}${datadir}/user3/
- install -p -m 644 file4 ${D}${datadir}/user3/
-
- # The new users and groups are created before the do_install
- # step, so you are now free to make use of them:
- chown -R user1 ${D}${datadir}/user1
- chown -R user2 ${D}${datadir}/user2
- chown -R user3 ${D}${datadir}/user3
-
- chgrp -R group1 ${D}${datadir}/user1
- chgrp -R group2 ${D}${datadir}/user2
- chgrp -R group3 ${D}${datadir}/user3
-}
-
-FILES_${PN} = "${datadir}/user1/* ${datadir}/user2/*"
-FILES_${PN}-user3 = "${datadir}/user3/*"
-
-# Prevents do_package failures with:
-# debugsources.list: No such file or directory:
-INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
diff --git a/yocto-poky/meta-skeleton/recipes-skeleton/useradd/useradd-example/file1 b/yocto-poky/meta-skeleton/recipes-skeleton/useradd/useradd-example/file1
deleted file mode 100644
index e69de29bb..000000000
--- a/yocto-poky/meta-skeleton/recipes-skeleton/useradd/useradd-example/file1
+++ /dev/null
diff --git a/yocto-poky/meta-skeleton/recipes-skeleton/useradd/useradd-example/file2 b/yocto-poky/meta-skeleton/recipes-skeleton/useradd/useradd-example/file2
deleted file mode 100644
index e69de29bb..000000000
--- a/yocto-poky/meta-skeleton/recipes-skeleton/useradd/useradd-example/file2
+++ /dev/null
diff --git a/yocto-poky/meta-skeleton/recipes-skeleton/useradd/useradd-example/file3 b/yocto-poky/meta-skeleton/recipes-skeleton/useradd/useradd-example/file3
deleted file mode 100644
index e69de29bb..000000000
--- a/yocto-poky/meta-skeleton/recipes-skeleton/useradd/useradd-example/file3
+++ /dev/null
diff --git a/yocto-poky/meta-skeleton/recipes-skeleton/useradd/useradd-example/file4 b/yocto-poky/meta-skeleton/recipes-skeleton/useradd/useradd-example/file4
deleted file mode 100644
index e69de29bb..000000000
--- a/yocto-poky/meta-skeleton/recipes-skeleton/useradd/useradd-example/file4
+++ /dev/null
OpenPOWER on IntegriCloud