summaryrefslogtreecommitdiffstats
path: root/poky/meta/recipes-core/zlib/zlib_1.2.11.bb
diff options
context:
space:
mode:
Diffstat (limited to 'poky/meta/recipes-core/zlib/zlib_1.2.11.bb')
-rw-r--r--poky/meta/recipes-core/zlib/zlib_1.2.11.bb19
1 files changed, 2 insertions, 17 deletions
diff --git a/poky/meta/recipes-core/zlib/zlib_1.2.11.bb b/poky/meta/recipes-core/zlib/zlib_1.2.11.bb
index 641051988..ef9431ae4 100644
--- a/poky/meta/recipes-core/zlib/zlib_1.2.11.bb
+++ b/poky/meta/recipes-core/zlib/zlib_1.2.11.bb
@@ -7,8 +7,6 @@ LICENSE = "Zlib"
LIC_FILES_CHKSUM = "file://zlib.h;beginline=6;endline=23;md5=5377232268e952e9ef63bc555f7aa6c0"
SRC_URI = "${SOURCEFORGE_MIRROR}/libpng/${BPN}/${PV}/${BPN}-${PV}.tar.xz \
- file://remove.ldconfig.call.patch \
- file://Makefile-runtests.patch \
file://ldflags-tests.patch \
file://run-ptest \
"
@@ -24,32 +22,19 @@ RDEPENDS_${PN}-ptest += "make"
inherit ptest
do_configure() {
- uname=GNU ./configure --prefix=${prefix} --shared --libdir=${libdir}
+ LDCONFIG=true ./configure --prefix=${prefix} --shared --libdir=${libdir} --uname=GNU
}
do_compile() {
oe_runmake shared
}
-do_compile_ptest() {
- oe_runmake test
-}
-
do_install() {
oe_runmake DESTDIR=${D} install
}
do_install_ptest() {
- install ${B}/Makefile ${D}${PTEST_PATH}
- install ${B}/example ${D}${PTEST_PATH}
- install ${B}/minigzip ${D}${PTEST_PATH}
- install ${B}/examplesh ${D}${PTEST_PATH}
- install ${B}/minigzipsh ${D}${PTEST_PATH}
-
- # Remove buildhost references...
- sed -i -e "s,--sysroot=${STAGING_DIR_TARGET},,g" \
- -e 's|${DEBUG_PREFIX_MAP}||g' \
- ${D}${PTEST_PATH}/Makefile
+ install ${B}/examplesh ${D}${PTEST_PATH}
}
# Move zlib shared libraries for target builds to $base_libdir so the library
OpenPOWER on IntegriCloud