summaryrefslogtreecommitdiffstats
path: root/poky/meta/recipes-core/update-rc.d/update-rc.d_0.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'poky/meta/recipes-core/update-rc.d/update-rc.d_0.7.bb')
-rw-r--r--poky/meta/recipes-core/update-rc.d/update-rc.d_0.7.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/poky/meta/recipes-core/update-rc.d/update-rc.d_0.7.bb b/poky/meta/recipes-core/update-rc.d/update-rc.d_0.7.bb
new file mode 100644
index 000000000..76d4312d8
--- /dev/null
+++ b/poky/meta/recipes-core/update-rc.d/update-rc.d_0.7.bb
@@ -0,0 +1,33 @@
+SUMMARY = "manage symlinks in /etc/rcN.d"
+HOMEPAGE = "http://github.com/philb/update-rc.d/"
+DESCRIPTION = "update-rc.d is a utility that allows the management of symlinks to the initscripts in the /etc/rcN.d directory structure."
+SECTION = "base"
+
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://update-rc.d;beginline=5;endline=15;md5=148a48321b10eb37c1fa3ee02b940a75"
+
+PR = "r5"
+
+# Revision corresponding to tag update-rc.d_0.7
+SRCREV = "eca680ddf28d024954895f59a241a622dd575c11"
+
+SRC_URI = "git://github.com/philb/update-rc.d.git \
+ file://add-verbose.patch \
+ file://check-if-symlinks-are-valid.patch \
+ file://fix-to-handle-priority-numbers-correctly.patch \
+ "
+UPSTREAM_CHECK_COMMITS = "1"
+
+S = "${WORKDIR}/git"
+
+inherit allarch
+
+do_compile() {
+}
+
+do_install() {
+ install -d ${D}${sbindir}
+ install -m 0755 ${S}/update-rc.d ${D}${sbindir}/update-rc.d
+}
+
+BBCLASSEXTEND = "native"
OpenPOWER on IntegriCloud