summaryrefslogtreecommitdiffstats
path: root/meta-rcs/meta-talos/recipes-phosphor/fans/detect-fan-fail.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-rcs/meta-talos/recipes-phosphor/fans/detect-fan-fail.bb')
-rw-r--r--meta-rcs/meta-talos/recipes-phosphor/fans/detect-fan-fail.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-rcs/meta-talos/recipes-phosphor/fans/detect-fan-fail.bb b/meta-rcs/meta-talos/recipes-phosphor/fans/detect-fan-fail.bb
new file mode 100644
index 000000000..5328f9102
--- /dev/null
+++ b/meta-rcs/meta-talos/recipes-phosphor/fans/detect-fan-fail.bb
@@ -0,0 +1,26 @@
+SUMMARY = "OpenBMC Talos II Detect Fan Fail Service"
+DESCRIPTION = "OpenBMC Talos II Detect Fan Fail Daemon."
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+inherit systemd
+
+DEPENDS += "systemd"
+RDEPENDS_${PN} += "bash"
+
+FILESEXTRAPATHS_append_talos := "${THISDIR}/detect-fan-fail:"
+SRC_URI_append_talos = " file://detect-fan-fail.sh \
+ file://detect-fan-fail.service \
+ "
+
+do_install_append_talos() {
+ install -d ${D}${bindir}
+ install -m 0755 ${WORKDIR}/detect-fan-fail.sh ${D}${bindir}/
+
+ install -d ${D}${systemd_unitdir}/system/
+ install -m 0644 ${WORKDIR}/detect-fan-fail.service ${D}${systemd_unitdir}/system
+}
+
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_SERVICE_${PN} = "detect-fan-fail.service"
OpenPOWER on IntegriCloud